Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The translated posts are not shown in the frontend. Solution: The issue is caused by the fact that the category is included in the Permalinks, but the categories are not yet translated.

To solve the issue, translate the post categories from WPML -> Taxonomy Translation -> Categories and save again the original posts.

This topic contains 4 replies, has 2 voices.

Last updated by ranaN 9 months ago.

Assigned support staff: Vincenzo.

Author Posts
March 10, 2019 at 11:54 am

ranaN

I am trying to:
> After translating one of our posts to Korean language, we can not see the translated page from original language.

Link to a page where the issue can be seen:
> Original Page link: hidden link

I expected to see:
> Korean translated page

Instead, I got:
> Nothing!

March 11, 2019 at 9:18 am #3309029

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello, thank you for contacting WPML Support!

From your debug info it seems like the Korean language is hidden.

You can verify from WPML -> Languages in the "Hide languages" section.

If you wish that only your user is able to see the hidden languages' posts, please enable the "Display hidden languages" option in Users -> Your Profile

Please let me know if this solves the issue or if you need further details.

Thank you

March 12, 2019 at 10:29 am #3320977

ranaN

I changed the hidden languages and removed Korean from it, but still, I receive 404 error page for the translation of my content.
Let me know please

March 12, 2019 at 1:08 pm #3322317

Vincenzo
Supporter

Languages: English (English ) Italian (Italiano )

Timezone: Europe/Rome (GMT+01:00)

Hello,

it seems like the issue is caused by the fact that the category is included in the Permalinks, but the categories are not yet translated.

Can you please try to translate the post categories from WPML -> Taxonomy Translation -> Categories?
- After the taxonomy translation is complete, please try re-saving the original posts.

Please let me know if this solves the issue or if you need further details.

Thank you

March 13, 2019 at 8:41 am #3330859

ranaN

My issue is resolved now. Thank you Vincenzo!