This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Shekhar Bhandari 1 year, 5 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
May 6, 2018 at 7:25 pm #2001085

ariela-2

I am trying to:

I have updated WPML to 3.9.4, which skipped 3.8.2
In update 3.8.2 there is a change for one of tha languages: Norwegian from NB to NO.

Now ones a week all of my website is crashing and WPML is off becouse it say that the Language table is incorrect

I debugged it and it looks like it's searching for NO and not finding it.

May 8, 2018 at 6:45 am #2024040

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

WPML is off because it says that the Language table is incorrect

Could you please provide me a screenshot showing the message?

Further, could you please perform the below steps and let me know if that helps?

Minimal Setup
If you disable all non-related WPML plugins, switch to one of the default themes, the problem persists or not?
NOTE:
+ Make a backup (both files and database) for your site before updating/proceeding anything (Always a good practice!).

Debugging
1. Please follow the debugging information provided here: http://wpml.org/documentation/support/debugging-wpml/ .
2. Repeat the action of creating the problem.
3. Copy and paste the contents of debug.log (log file inside the /wp-content/ directory) here for me to see.

Look forward to your reply.

Thanks

May 15, 2018 at 11:37 am #2137372

ariela-2

I have managed to find the reason to this:

File "lang-data.php"

The code for Norwegian Bokmai was changed from NB to NO

'Norwegian Bokmål' => 'no',
'Norwegian Nynorsk' => 'nn',

The problem starts with the method:
static function languages_table_is_complete() {

It checks that the table has all the codes, BUT it sees that I dont have the code 'no' since I have the code 'nb'

This marks the website as NOT setup completed, and this is making the website loose all of it's translation!

I have changed this file back to nb and raizes this flag

define('ICL_REMOTE_WPML_CONFIG_DISABLED', true);

About your questions/debug sudgestion

1. Minimal setup - I cannot remove WPML - If I remove it it's the same as it shuts down, the problem is in it's shutting down.
2. When I switch all non WPML related plugins - If the system already marked WPML setup incomplete then it's still dead, if it's not then nothing changes.

May 16, 2018 at 11:39 am #2156001

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Did you have a backup file of your site? So I can debug this issue further and report it to the developers if needed. I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

This info is private and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues need some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

The topic ‘[Closed] After update of Norvegian from NB to NO my website crash’ is closed to new replies.