This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Itamar 1 year ago.

Assigned support staff: Itamar.

Author Posts
June 5, 2019 at 9:12 am


Hey WPML-Team,

we updated our WPML via ftp and updated all other WPML-Addons via the WPML-CMS.
Everything worked fine, but some countriesites are not accessable.
It redirects you instead back to the german site.

We refreshed the permalink structere and deleted all cashing plugins.

The funny thing is, that this is our testingsite and we have this same setup on our livesetup and it works.

We will give u login information, because the website is not accessable from the frontend.

June 5, 2019 at 6:02 pm #3963293


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for the access details.

You have 20 languages configured on your site with WPML.
Could you please tell in which languages I can see this problem that you are mentioning?

You wrote: "The funny thing is, that this is our testingsite and we have this same setup on our livesetup and it works."
Does it work on the live site after you have updated WPML and its add-ons to the latest versions (the same thing that you did on the staging site)?

I look forward to your reply!


June 6, 2019 at 7:12 am #3966359


Hey Itamar,

for example "NL" when you go on the "NL" home you will be redirected to our german home.
We thought about a redirect in yoast, but there is no redirect.

Yes on our livesetup we also updated it and there is no problem (only woocommerce multilingual isn't updated).

Normaly we would make a new installation of our site, but this is our third try to bring the live site on our testing-area.

We always use backups from last night and on the livesite it is working.
Maybe you have an idea.


June 6, 2019 at 8:57 pm #3971955


Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Jerome.

So if I understand, correctly the problem is happening when you try to migrate your live site which is updated and working fine to the staging site and there the problem is happening.
Is this correct?
I've seen cases where a migration broke things on the site.
Are you migrating with UpdraftPlus?
Do you have the possibility to migrate the site in another method, maybe the Duplicator plugin?

Also, on your first post, you wrote: "we updated our WPML via FTP and updated all other WPML-Addons via the WPML-CMS."
Where did you do that on the staging site (hidden link)?
Why did you update WPML through FTP and not in the usual way through Plugins?
What was WPML's version before the update?

I've checked things on your site. First, I thought that it would be useful to re-save the permalinks. But it didn't help to solve the problem.

Then I noticed that if I want to edit the homepage in the default language by pressing the edit link on the frontend, I get a page which is not translated into any other language. Please see the attached screenshots.

I think that in this stage it would be good to try the troubleshooting section.
First, take a backup of the DB of your site.
Go to WPML -> Support -> Troubleshooting (link)
Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Disable cache for language switcher templates'
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Set language information'
- 'Assign translation status to duplicated content'
- 'Fix terms count'
- 'Fix post type assignment for translations'
Please try also the options on the troubleshooting section but don't reset WPML at the bottom of the page.

*** Please make a backup of your database before using this.**

Please let me know the results of this and answer my questions.


The topic ‘[Closed] After Update unable to enter some countryhomes’ is closed to new replies.