This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 6 replies, has 2 voices.

Last updated by John de Lange 1 month ago.

Assigned support staff: Itamar.

Author Posts
September 10, 2019 at 3:38 pm

John de Lange

I am trying to:

I updated to latest version of all WPML plugins. Now all product translation show a 404 error?

Link to a page where the issue can be seen:

hidden link
or check any link from Latest changes on front page: hidden link

I expected to see:

The English translation of my Dutch articles.

Instead, I got:

404 error

September 10, 2019 at 4:37 pm
September 10, 2019 at 4:51 pm #4547523

John de Lange

I had some support by Itamar in the chat. He suggested to switch the theme to standard and switch off all plugins. I found the incompatible plugin: Page Builder by SiteOrigin. When I activate that plugin I get the 404 error's in my translations.

September 11, 2019 at 6:55 pm #4555965

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Jhon and sorry for the late reply here.

Thanks for following my suggestions. This is weird that the SiteOrigin plugin is causing this issue.
Do the products pages on your site built with the SiteOrigin plugin?
Do you allow me to temporarily deactivate the SiteOrigin plugin on your site to see the issue and check things?

It would be better to try that on a staging site rather than on the live site. So if you have a staging site, please share the access details with me. I'm enabling a private message for the next reply.

Thanks,
Itamar.

September 11, 2019 at 6:59 pm #4555973

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi again.

I've just re-checked the links that you gave me, and I see that the problem is solved. The English translations of my Dutch articles are not resulting in a 404 page. Please see the attached screenshot.
Have you fixed this issue already?

September 11, 2019 at 7:26 pm #4556153

John de Lange

No, the issue is not solved. This is my live site. I disabled the Page Builder by SiteOrigin plugin to make it work partially. The footer is missing because of that. If I switch it on, the translations get 404's....which is very bad voor SEO.

What do you want me to do? Go to my latest backup or do you want to find a fix. I guess this is a compatibility issue between a pagebuilder plugin and WPML.

September 12, 2019 at 11:35 am #4560587

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

For now on your live site, if you don't want the SEO of your site to be damaged, I suggest that you restore the latest backup.

Do you have a staging site where this issue can be reproduced?
If so, then please activate SiteOrigin plugin on that site and check for any PHP errors.
Please check this page for instructions.
https://wpml.org/documentation/support/debugging-wpml/
Look under the headline "Enabling the built-in debugging feature in WordPress".
To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);.

Change it to:

define('WP_DEBUG', true);
// Enable Debug logging to the /wp-content/debug.log file
define('WP_DEBUG_LOG', true);
// Disable display of errors and warnings which is recommened on a live site.
define('WP_DEBUG_DISPLAY', true);

In this case, the errors will be saved to a debug.log log file inside the /wp-content/directory.
If you can paste your debug.log to pastebin.com and provide me that link, it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess in discussion).

Please, could you provide me the additional Info?

Thanks,
Itamar.

September 12, 2019 at 12:15 pm #4560829

John de Lange

My issue is under investigation by Bruno Kos as it is an incompatibility with the page builder. Thank you!