If you are having a notice about writing the .mo files please read this doc

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 4 years, 8 months ago.

Assigned support staff: Bruno.

Author Posts
March 5, 2015 at 3:09 pm #571807

Leif-Erik

I am trying to: Get my language switcher to point to correct translated URL's at the Homepage translated pages

I visited this URL: hidden link

What's wrong: From main index page, if I want to switch language to Swedish. It brings up most recent blog post done (in archive) and not the translated "index" page. It seems to be pointing to wrong URL modehusetchic.se/?cat=10&lang=sv (same for the german URL).

It seems only to effect the first Index page Language Switcher options

Had same problem a few weeks back and I created a TEST blog post and it went away. Tried this and it dosent work this time.

March 5, 2015 at 6:32 pm #572004

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

When I access your site, I am redirected to the page hidden link.

I clicked on the Home link to access the homepage and I saw the problem.

Please as a test, could you disable all non-WPML plugins and see if the problem persists?

Thank you.

March 17, 2015 at 7:37 pm #580547

Leif-Erik

Hi,

I disabled all non-WPML plugins and the problem presisted and from the language switcher it points to "posts archive" page.

March 18, 2015 at 9:35 pm #581559

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

The new version, 3.1.9.3, was released. Please could you update? If you have registered your site, you can update from the WordPress dashboard.

If not, please, log into your client area and download the latest version ( https://wpml.org/account/downloads/ ). Then extract the files on your computer and with FTP replace the old files on your server (wp-content/plugins/).

Please make a full backup of your site before upgrading WPML.

Please let me know if this solves the problem and if I can help with anything else.

Thank you.

March 19, 2015 at 5:22 am #581671

Leif-Erik

Hi,

All plugins are the most up to date, even 3.1.9.3 - but unfortunately the language switcher is still pointing to the incorrect page form the homepage start page.

March 19, 2015 at 12:56 pm #582110

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

I need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Please let me know exactly what steps should I follow to see the problem.

Note: Please make a full backup of your site.

Thank you.

The topic ‘[Closed] After updating – Language Switcher points to Archived Blog Posts’ is closed to new replies.