Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by Otto 5 years, 3 months ago.

Assigned support staff: Otto.

Author Posts
August 23, 2016 at 9:50 am #1015793

ferjoltO

Hello,
After i upgraded the WP to 4.6 and WPML to 3.5.1, i'm facing a strange problem. When editors translate a post from the default language to any other language and directly publish the new post, it wont keep the relation with the original post from the default language. It just shows up as new and independent post.
When we do the same thing but don't publish it, but Save it on Draft, and after that we publish it, the new post will perfectly keep the relation between languages and with the original post.
Also, when someone tries to add a new post at any other language than the default one, the page loads continuously for many seconds and then stops on the screen attached. From the source code, i saw that it stops loading on this instance:

[...]
<div id="postbox-container-1" class="postbox-container">
<div id="side-sortables" class="meta-box-sortables"><div id="icl_div" class="postbox " >
<button type="button" class="handlediv button-link" aria-expanded="true"><span class="screen-reader-text">Toggle panel: Language</span><span class="toggle-indicator" aria-hidden="true"></span></button><h2 class='hndle'><span>Language</span></h2>
<div class="inside">
		<div id="icl_document_language_dropdown" class="icl_box_paragraph">
			<p>
				<label for="icl_post_language"><strong>Language of this post</strong></label>
			</p>

						<select name="icl_post_language" id="icl_post_language" >
									<option value="en"  selected='selected'>
						English					</option>
										<option value="fr" >
						French					</option>
										<option value="sq" >
						Albanian					</option>
								</select>
			<input type="hidden" name="icl_trid" value=""/>
		</div>
				<div id="translation_of_wrap">
			
				<div id="icl_translation_of_panel" class="icl_box_paragraph">
					<label for="icl_translation_of">This is a translation of</label>&nbsp;
					<select name="icl_translation_of" id="icl_translation_of"  disabled='disabled'>

It seems that it has difficulties to load correctly.

I tried to disable and remove the plugin and then to upload and install it again, but the problem seems to persists.

I should mention that this happened with any of 2 non-default languages. With the default one, it loads perfectly.
I don't know how or why, but this to problems seems to be related somehow and i'm not getting it how to resolve them. Would you try to help me on this issue, please?

Thank you in advance.

P.S. One other support threads i have provided you with login details on WP and FTP. If you can't access them anymore, please, let me know and I will give them to you again.

new-post-english.jpg
August 23, 2016 at 2:16 pm #1016640

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

The WP memory limit needs to be increased. PHP memory is fine but WordPress uses 40Mb as default. Minimum requirements for WPML are 128Mb: https://wpml.org/home/minimum-requirements/

Can you please increase the memory limit to 256MB:
https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

Add this code to your wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '256M');
define( 'WP_MAX_MEMORY_LIMIT', '256M' );

Paste it just before:

/* That's all, stop editing! Happy blogging. */

If the issue persists I need you to do the following test:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Thanks for your cooperation.

Let me know your results, please.

Kind Regards,

Otto

August 23, 2016 at 2:36 pm #1016749

ferjoltO

Dear Otto,
Thank you for your reply. Unfortunately this is not the case of memory limit. On wp_config i had 4096 memory limited allocated to wp:

define( 'WP_MAX_MEMORY_LIMIT', '4096M' );

...and it's not the case.
Any other suggestion, please?
Thank you!

August 23, 2016 at 2:41 pm #1016769

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

But it looks like (according to the debug information) that the WP memory limit is using 40M

I suggest you add this line:

define('WP_MEMORY_LIMIT', '512M');

Did you try this? Same results?
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Let me know your results, please.

Kind Regards,

Otto

August 23, 2016 at 3:27 pm #1016975

ferjoltO

Thank you for your suggestion but this is how the wp-config looks like:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '1024M');
define( 'WP_MAX_MEMORY_LIMIT', '4096M' );
define( 'FS_METHOD', 'direct' );
define('AUTOSAVE_INTERVAL', 86400 ); // seconds
//define('WP_POST_REVISIONS', false );
define('WP_DEBUG', true);
define( 'WP_DEBUG_DISPLAY', false );
define( 'WP_DEBUG_LOG', true );
define( 'EMPTY_TRASH_DAYS', 7 ); 
define( 'DISALLOW_FILE_EDIT', true ); 

I don't get how the debug can show that memory limit is 40M. Something is wrong somewhere there... Any suggestion?
Thank you!

August 23, 2016 at 3:31 pm #1016979

ferjoltO

I just checked the debug page of wpml, and this is what it say now about memory limit:

{"MemoryLimit":"2048M","WP Memory Limit":"1024M","UploadMax":"5M","PostMax":"8M","TimeLimit":"120","MaxInputVars":"1000","MBString":true,"libxml":true}
August 23, 2016 at 5:35 pm #1017642

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you, it must have been an error in the Debug log I have available then. Please apologize for the inconvenience.

Is it possible for you to do the compatibility test?:
-Back up your site first
-Deactivate all the plugins that are not related to WPML
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

If not, To further debug the problem I'd like to replicate your site locally. For this, I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

Please refer screenshot attached, remember to enable the filters and exclude this:
+ wp-uploads
+ cache
+ media
+ archive

Excluding these things will help in keeping the snapshot size minimum

:: Duplicator instructions
hidden link

. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

Once the problem is resolved I will delete the local site.

I am enabling private message for your next reply so that you can send me snapshot link and admin details of account you will create for me.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Thank you for your cooperation for debugging this issue.

Kind Regards,

Otto

August 23, 2016 at 8:23 pm #1017881

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks a lot but the package is not complete, it had errors while processing. I tried to create a new one and it failed too.

To reproduce your site locally and further debug, can you please provide a copy of the DB and a zip file with the wp-content folder (excluding uploads)?

You will need to upload them to some service (like Dropbox, Google Drive or WeTransfer) because of the size of the files.

I'll set a private reply again so you can share the link safely.

Thanks for your cooperation.

Kind Regards,

Otto

August 24, 2016 at 1:40 pm #1019367

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks! I managed to clone your site and reproduce the issue locally.

I didn't manage to find the cause of the issue yet. I'll investigate further and get back to you soon.

Thanks for your patience and understanding.

Kind Regards,

Otto

August 24, 2016 at 6:22 pm #1020218

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thanks for your patience.

Do you have a backup of the site before the update? From which version were you updating?Can you provide us the backup copy pre-update?

I set next reply as private again, in case you can share a link to download it.

Thanks for your cooperation.

Kind Regards,

Otto

August 26, 2016 at 1:41 pm #1024427

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Thank you.

I downloaded the files. I will reproduce the old site and run the upgrade process to try to figure out what happened here.

I'll get back to you as soon as I have news.

Thanks for your patience and cooperation.

Kind Regards,

Otto

August 26, 2016 at 5:51 pm #1024793

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I tried the old copy, with WP 4.5 and 4.6. In both cases, it asked me a DB update and the issue is still present there.

Are you sure about the WP version? Was it working at that time?

I'm truly sorry for bothering with all this, but I need to find clear steps about how to reproduce the issue so we can figure out what happened here.

Thanks for your cooperation.

Kind Regards,

Otto

The topic ‘[Closed] After upgrade, WPML wont keep relations on post translations’ is closed to new replies.