This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Bruno 2 months, 2 weeks ago.

Assigned support staff: Bruno.

Author Posts
July 31, 2019 at 7:27 pm #4317363

Xavier

I am trying to: Upgrade WPML to v 4.2.7.1 (from 4.2.6) and string translation to v 2.10.5.1 (from 2.10.4 )

Link to a page where the issue can be seen: I rolled back the update so there is no live version of this error

Instead, I got: After upgrade all translated strings in French were not displayed.

I give give access if required.

August 1, 2019 at 12:26 am #4317887

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Yes, we will need to check why these strings are not being translated.

I'll need to request temporary access (wp-admin and FTP) to your site - preferably to a test site where the problem has been replicated if possible - in order to be of better help.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Note:

*** Please let me know exactly what steps should I follow to see the problem.

*** Please, can I install the Duplicator plugin (or All in One Migration) to make a copy of your site and install it on my test environment? This will help me debug the problem.

*** Note: Please make a full backup of your site.

Privacy and Security when Providing Debug Information for Support: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Thank you.

August 2, 2019 at 7:46 pm #4332387

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Thank you. I installed your site in my test environment and after upgrading, I noticed that the secondary language strings are still showing in French. Is there any specific string that has lost the translation?

Basically, I just updated the plugins and refreshed the page in the secondary language. Also, I noticed that you are using a cache plugin, which is probably connected to your server. Maybe that's why I couldn't replicate the problem.

Thank you.

August 6, 2019 at 2:04 pm #4348145

Xavier

Ok - I also replicated the site on my local dev and didnt have the issue.

August 6, 2019 at 3:53 pm #4349261

Xavier

All strings are not translating for me. If you go here it becomes more apparent:
hidden link

I've switched our server back to Apache (from litespeed) and disabled all caching.

We are running PHP 7.1.30 and SQL 5.5.5-10.3.17-MariaDB.

Any idea what could be causing this?

August 7, 2019 at 12:26 am #4350905

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you. Unfortunately, I still can't see the problem. In the case of this page, I noticed that the strings are displaying correctly. I will attach a picture for you to see.

I noticed that maybe only the names of the universities are not translated. Is that what you are reporting?

The topic ‘[Closed] after upgrading to latest ver – strings no longer working’ is closed to new replies.