This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 2 voices.

Last updated by rokJ 3 months ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 10, 2019 at 11:16 pm

rokJ

Hi,

I'm writing about a problem that was already reported from another user some time ago. We have exactly the same issue, but our WCML is already up to date. Down here I'm copying what has already been written + the whole thread.

---

I am trying to: update the stock. Some variations are back in stock, so we've changed the stock.
After saving the product is back in stock and visible in the default language, but not in the second language.
This happens for variable products as wel as for simple products.

I expected to see: the product back-in stock in both languages.

Instead, I got: the product only back in stock in the DEFAULT language. When we open the translation to the 2nd language and save this again it is visible in 2nd language. But that takes too much time to do this for all products that are back in stock in our shop.

https://wpml.org/forums/topic/after-variation-update-the-product-is-not-visible-in-2nd-language/

---

Is there a way to make the translations always visible no matter if you update the original item? I created an account for you on our staging site so you can test and replicate the issue.

Before you begin to test I must inform you that when we built our website English was the default language, after that we added the second language (Slovenian) and now we've made the second language the default one. Even though we've changed the default language to Slovenian, English is still the default language for products when we want to edit them. The main website is now in Slovenian language.

You can replicate the problem this way:
- open a category page on the front end to se the product you want to edit (in Slovenian language)
- enter into the English edit screen of the product and go to Inventory > uncheck "Manage stock?"
- save/update the product
- clear the WP Rocket cache first and after that preload it than go to the Slovenian version of the website to see the result; at the same time check the English version (domain.com/en) and you'll see that on the English version the product is still visible, but on Slovenian is not
- go again into the product edit screen and click the pencil to edit the Slovenian translation
- Save & close the screen (the "Translation is complete" box should already be checked)
- refresh the Slovenian site to see the Slovenian translation again

Please let me know when you run a test what could be the problem. We regularly edit products that come back in stock and to resave translations every time is not a good option.

Thank you.

July 11, 2019 at 10:46 am #4188829

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issues.

I am unable to access your site it seems it is IP restricted.

I hope you have already tired the stock synchronization option suggested in the ticket
https://wpml.org/forums/topic/after-variation-update-the-product-is-not-visible-in-2nd-language/

Please provide me a snapshot (copy) of your site, So that i can try to reproduce and proceed with debugging without disturbing your live site.
You can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled private fields for you to securely share the details

Kind regards
Raja

July 11, 2019 at 4:36 pm
July 12, 2019 at 12:24 pm #4198603

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am unable to reproduce the issue following your steps, I have recorded my steps please check hidden link.

Please let me know if am missing anything.

Kind regards
Raja

July 12, 2019 at 12:38 pm #4198759

rokJ

Hi,

all you did was fine, and as I said, the product and its changes are instantly visible on the product page in both languages. That's what you did in the video.

What you didn't do in the video was to check if the product is also visible on its category page. This is where we have a problem. Since you edited a Tosca Blu product you should check if after you edit, save and clear the cache, the product is visible under the Tosca Blu menu tab in both languages. Same applies for all other brands. There you'll see that on the English version the edits (after cache clearing) are visible, while on the Slovenian language the product is missing until you resave the translation one more time.

Try this situation with an older product that you'll find on the 5th page in the product tabs or higher. It's important that before you try to recreate the situation, you go check for the product on the website to see if it's visible.

Thank you.

July 15, 2019 at 1:06 pm #4211317

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,
Kindly apologize for the delay,

I have tried the steps mentioned but it seems you have disabled WP-Rocket and I am unable to reproduce the issue.
Does it solve the issue?

Maybe the best I can do is clone your site to our private server and do the testing without disturbing your site. Let me know if that is okay for you I will send the migration details in my next reply.

Kind regards
Raja

July 15, 2019 at 1:09 pm #4211329

rokJ

Hi,

I have enabled it again now. Please try again.

July 16, 2019 at 12:48 pm #4220199

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

I am getting a different issue now, the English page is disappearing after the update. My local setup is unable to handle a few request, I would like to test this in a server environment to isolate any issues related to the server.

I would request you please clone your site to our private server migration details will be sent in my next private reply.

Kind regards
Raja

July 16, 2019 at 12:50 pm
July 21, 2019 at 10:38 am #4252097

rokJ

Hi,

we were testing the "Hide English" option so this is probably the cause why you were not seeing it.

Right now the issue is not present anymore so I'll mark this issue as resolved.

Thank you.