This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:all import and wpml not adding variations in translated product

Solution:i was able to re import your products with the new edited xls files. I had just added a connector field to each file so we can use that as the unique identifier, which allows WP All Import to connect these products which prior they werent and i believe this is what was causing issues.

Relevant Documentation:

This topic contains 19 replies, has 3 voices.

Last updated by Bobby 1 year ago.

Assigned support staff: Bobby.

Author Posts
October 5, 2018 at 2:54 pm

kathleenV

I am trying to:translate the variations of the products

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

I imported all the products in woo commerce in dutch, and an also imported the french translation with all import plugin, but all the variations of the french products are missing. All import thinks it my be a wpml issue, so they asked me to get help form you.

October 8, 2018 at 6:26 pm #2797090

Ricardo Alday

Hi,

Thank you for contacting WPML support.
Did you import the variations as outlined on this tutorial? - hidden link

If so, can you upload a copy of your CSV files to Dropbox, Google Drive or similar so we can test them out?

Thanks,
Ricardo

October 8, 2018 at 6:38 pm #2797097

kathleenV

Hi Ricardo

I did try to add variations like the link you send me.

Wich mail adrress can i assign to the dropbox file, so you have access?

Kind regards
Kathleen

October 8, 2018 at 7:09 pm #2797132

Ricardo Alday

Use ricardo.a@onthegosystems.com

Thanks.

October 9, 2018 at 12:27 am #2797592

Ricardo Alday

Thanks. I'm not sure I did it correctly. How/where are you mapping the "variant"?

October 9, 2018 at 6:23 am #2798347

kathleenV

Hello,
The variant is the column "variant".

I added a movie to show how ik work: hidden link

Kind regards

Kathleen

October 10, 2018 at 5:25 am #2802945

kathleenV

Hello

Can i have a solution please? My client is getting out of patience...

Kind regards

Kathleen

October 10, 2018 at 7:52 am #2803238

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

Ricardo is currently offline , and i will be taking over this ticket, if possible please share with me the dropbox file to bobby.k@onthegosystems.com.

additionally , when you go through the procedure for the secondary language using WP All Import + WPML All Import what are your results when you add the variant ? or do you not see the option to add the variant at all ?

October 10, 2018 at 8:07 am #2803299

kathleenV

Hello, You should have acces to the dropbox file now.

Kind regards

Kathleen

October 10, 2018 at 6:10 pm #2805391

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi Kathleen,

when i currently view your French product translations i can see the variants within them, for example in my screenshot you can see the "Noir" , "Chair" variants for the product "Bande élastique silicon 50 mm"

are there specific products that do not have the variables.

October 11, 2018 at 7:01 am #2806796

kathleenV

Hello

I see that the variations are added, but not shown in "atributes" (eigenschappen in dutch), see screenshot attached.

I did the import with the WPML all import plugin, and asked for all the attributes to be added as variation (see screenshot).

The problem is dat all the variations are added, but not visible in attributes, so there is no possibility to make a choice for the clients in the frontend.

October 11, 2018 at 6:49 pm #2809551

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

please, click on the WPML > WooCommerce Multilingual > Settings. At the end of the page, click on the "Troubleshooting page" link. Check the "Sync products variations" option and click on the "Start" button.

After following this step, please let me know if the problem persists

also please review the following thread regarding using only numbers without any text or characters in the "translation connector" column

https://wpml.org/forums/topic/bilingual-products-and-attributes-are-not-syncing-using-wp-all-import/#post-1195696

you can see how the "connector column" works here [its essential your ARTIKELNR. column ]
hidden link

October 12, 2018 at 10:01 am #2811549

kathleenV

Hello

I did follow the steps you mentioned but the problem is still there.. I already looked ceveral times to all the movies that are online, but i cannot found a solution. This is really urgent...
Also i get a notification that the content is empty, when i want to import the translations.
Could you please take a look in the admin section to solve this? In the first mail, i added the wp logins.

Kind regards
Kathleen

October 15, 2018 at 7:24 am #2816404

kathleenV

Hello,

Can i please get a solution? It's been 10 days now and my client is getting really impatience..

Please don't ask me to view tutorials anymore, i have watched them a 100 times and i cannot found any solution. I'm sorry, but i really need some help..

Kind regards

Kathleen Verhelle

October 15, 2018 at 5:05 pm #2818384

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello Kathleen,

i apologize for the waiting time due to the weekend, i am currently testing this locally and will be updating you shortly