This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bruno 1 year ago.

Assigned support staff: Bruno.

Author Posts
September 13, 2018 at 7:12 am

arusyakB

I am trying to upload a csv file for woocommerce products but the import is terminated. I checked with the hosting support team but the errors show the issue is caused by the plugin. Could you pls check and help to fix it?

Thanks a lot in advance.
Arus

September 15, 2018 at 8:01 am #2737369

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Thank you for contacting us. Please, my sincere apologies for the delay in answering.

I've tried using Duplicator on your site to test in my testing environment what may be happening but it seems the PHP Zip extension is not enabled. I'll attach an image for you to see.

Please, can I install All in One Migration to try to export your site and test it in my testing environment? Also, did your host say what error message is happening on your site?

Thank you.

September 15, 2018 at 8:38 am #2737394

arusyakB

Hi Bruno, thanks for your response. I got the error message but have not saved it. Yes you can install the plugin. Is there a way I can enable the PHP zip extension or will you do that?
Thanks,
Arus

September 18, 2018 at 1:16 am #2742882

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hi,

This may be happening at the memory limit. I tested this in my testing environment and it worked correctly.

I've noticed that you are using 40MB of memory. The WPML requires at least 128MB: https://wpml.org/home/minimum-requirements/

Please, could you increase the memory limit for WordPress? To do it, please open the wp-config.php file in the root of your WordPress installation and after the opening PHP tag, add these lines:

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

E.g.:

<?php

define( 'WP_MEMORY_LIMIT', '512M' );
define( 'WP_MAX_MEMORY_LIMIT', '512M' );

Then save the file and using your FTP client, upload wp-config.php to your server. After following these steps, please try again to import the content.

If the problem persists, please, I can test this on your server (as in my testing environment, it worked correctly).

Thank you.

September 18, 2018 at 7:47 am #2743889

arusyakB

Hi Bruno,
I set the memory limit to 512M but the issue still exists. Could you pls help? Pls feel free to do the tests and upload any plugin that would help you set the issue.
Thanks.

September 19, 2018 at 5:54 pm #2749705

arusyakB

Hi Bruno, I am still having the issue with the upload which very urgent and does not allow to go further with anything. I checked again with the hosting team. they see no errors now after having fixed the memory issue. They tried the upload & it worked on their side. Could you pls advise on the issue?
Thanks a lot.

September 19, 2018 at 7:57 pm #2749886

arusyakB

Updated the new version of wpml, the issue is still there.

 Pls note admin pass is now F995644389tfu# 

. M[/php]x execution time is 300.

September 20, 2018 at 2:13 am #2750347

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

Hello,

Sorry for the delay. I'll check again and soon I'll contact you.

Thank you.

September 20, 2018 at 3:17 am #2750698

Bruno
Supporter

Languages: English (English ) Portuguese (Brazil) (Português )

Timezone: America/Sao_Paulo (GMT-03:00)

This does not seem to be related to WPML. After a few tests on your site, I deactivated all WPML plugins (WPML, its add-ons, and WooCommerce Multilingual).

This takes a long time to start importing (almost 3 minutes) and after a while, it gets stuck. Even with WPML disabled.

With WPML enabled, I kept running for some time and it took a few minutes to import the products (6 minutes). I'll attach an image for you to see.

Note that import is slow even with WPML disabled. That is, it does not seem to be related to WPML. Also, note that leaving running for a few minutes the import was made.

Please, could you check?

Thank you.

The topic ‘[Closed] All import product import is terminated’ is closed to new replies.