This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 53 replies, has 2 voices.

Last updated by Mihai Apetrei 1 month, 1 week ago.

Assigned support staff: Mihai Apetrei.

Author Posts
March 27, 2020 at 3:23 pm #5781019

Vasileios Chouliaras

Hi i have a problem with all in one seo pro plugin.

We have latest version of all plugins (wp, woo, wpml, aio)
We have translate all our products.

Now we want to edit the seo of the first language.
On save i deletes the seo on second language of the program.

I tried this

https://wpml.org/forums/topic/home-page-meta-title-and-description-overwrite-other-home-page-translation/

but i couldnt find these options at wpml settings

What can i do?
Thanks

March 27, 2020 at 4:03 pm #5781229

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

March 28, 2020 at 11:42 pm #5786473

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for the credentials.

I can confirm that there is no public url (only you and me can see it) and I can also confirm that the credentials worked perfectly.

I am spending more time on this and I will get back to you as soon as I have more feedback.

I will leave the ticket assigned to myself for the moment.

PS: I am not working on the weekend so I will get back to you at the beginning of next week.

Kind regards,
Mihai

March 30, 2020 at 8:55 am #5792517

Vasileios Chouliaras

ok i am here if you need something. I hope to find a solution soon because i have to work on this. Thanks for now

March 30, 2020 at 7:40 pm #5798685

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for your patience.

So I made sure that the fields are set to Translate.

Now, if you simply make a small change on the default language of a page and save it, when you go back to the translation, the fields should show up.

Please let me know if this works for you now.

If not, please give me an exact example with a specific product or a page so that I can further investigate.

Kind regards,
Mihai

March 31, 2020 at 10:43 am #5802945

Vasileios Chouliaras

Please check this video to see the error. (make it private please)

hidden link

Thanks

March 31, 2020 at 7:24 pm #5807523

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there and thank you very much for sharing the video with me. It helped me understand better what you were referring to.

Here's why that's happening:

- That product was initially created from the English language (I will show you a screenshot below where we can see that)

So there are 2 methods that you can use:

1. (I recommend this one)

- First set the SEO options in the language from where the product was created initially (on our example, set the SEO options here first: hidden link)

- Then, set the SEO options in the translation (in our case, here: hidden link)

2. If you first set the SEO information in the translated product page, when you enter the SEO info in the default language product page, before clicking save, check the "Minor edit - don't update translation" box (because if you don't check that box, it will set the Greek translation to the "Translation needs update" status and you lose your inserted SEO text)

Kind regards,
Mihai

April 1, 2020 at 12:54 pm #5813039

Vasileios Chouliaras

thanks for your reply. problem still exists.

Also i cant translate the images.

If it helps. First i had as first language English and now i changed to be the first Greek

April 1, 2020 at 5:11 pm #5816389

Vasileios Chouliaras

thanks for your time.
Check pls this video. If possible urls and images make it private, Thanks

hidden link

April 1, 2020 at 7:26 pm #5816973

Vasileios Chouliaras

on debug i get this (if it helps)
<input type="hidden" id="wcml_save_files_option_nonce" name="wcml_save_files_option_nonce" value="04a1fe2d9d">

April 1, 2020 at 8:36 pm #5817137

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

This doesn't happen to me, unfortunately.

My recommendation is to try to use a different browser - maybe you have specific browser extensions that are creating this issue.

Please let me know if this is happening even when you try with a different browser.

If this doesn't get resolved, I will need you to recreate the issue from scratch one of our sandbox servers that I can set up for you (this is the process needed in order to be able to forward this to our Compatibility team) - but as I said, this doesn't happen for me and if you want, I can also create a screen recording where you can see this is not happening on my side.

I also marked my last reply with the photo attachments as private.

Kind regards,
Mihai

April 1, 2020 at 9:02 pm #5817177

Vasileios Chouliaras

Hi due to many tests on my site i found a solution (maybe).
When i deactivate the WooCommerce Multilingual add on it works ok.

Is there any conflict with latest version of woocommerce?

I tried many older versions of
WooCommerce Multilingual
WPML Multilingual CMS
String Translation
Translation Management
Media Translation

But without luck.
I deactivate the WooCommerce Multilingual add on and it seems to be ok now.

I work on this site 6-8 months now. All worked perfect. But i made updates and since then i met this problem.

i dont know if it is from latest version of woo or latest version of this add on.

About browser i installed also mozilla. I tried 3 different pc and still the same.

Thanks for now

April 2, 2020 at 11:57 am #5822091

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Unfortunately, I'm not aware of any compatibility issues with WooCommerce regarding this matter.

I am sorry to hear that this doesn't work for you but for me, it works just fine.

Would you like me to set up a sandbox environment for you to try to recreate the issue from scratch?

The idea of this sandbox is that it is a clean WordPress install where we don't install anything else except the theme and plugins that are needed to recreate the issue + the WPML plugin.

Please let me know if you would like me to set that up for you.

Kind regards,
Mihai

April 2, 2020 at 12:05 pm #5822107

Vasileios Chouliaras

If is possible yes.

April 2, 2020 at 6:08 pm #5825631

Vasileios Chouliaras

Hi i start to work on demo you send me.

I have this. Does it helps? Also if is possible can you make me a video from your side and send me to check pls? Test it on my site. Thanks

2020-04-02T18:02:18+00:00 CRITICAL Uncaught InvalidArgumentException: Argument ID must be numeric and greater than 0. in /home/mysite/new.mysite.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php:28
Stack trace:
#0 /home/mysite/new.mysite.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element-factory.php(41): WPML_Translation_Element->__construct(0, Object(SitePress), NULL)
#1 /home/mysite/new.mysite.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element-factory.php(33): WPML_Translation_Element_Factory->create_post(0)
#2 /home/mysite/new.mysite.com/wp-content/plugins/wpml-translation-management/classes/words-count/hooks/wpml-tm-word-count-refresh-hooks.php(39): WPML_Translation_Element_Factory->create(0, 'post')
#3 /home/mysite/new.mysite.com/wp-includes/class-wp-hook.php(289): WPML_TM_Word_Count_Refresh_Hooks->refresh_post_word_cou μέσα στο /home/mysite/new.mysite.com/wp-content/plugins/sitepress-multilingual-cms/classes/translations/class-wpml-translation-element.php στην γραμμή 28