This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 39 replies, has 3 voices.

Last updated by Laura 2 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
May 16, 2019 at 11:45 am #3825589

carolinev-8

I am trying to: Have full calendar page and individual events pages show up in all languages

Link to a page where the issue can be seen: hidden link (this happens on the Dutch pages too)

I expected to see: A page similar to this German version, except in English/Dutch: hidden link

Instead, I got: The page cannot be found, as you can see

The German site shows the full calendar, sidebar calendar and individual events pages, but when you switch to English or Dutch, only the sidebar calendar works. The full calendar page (like this hidden link) and individual events pages can't be found. I also can't use the language switcher when I'm on the full calendar page - only German is available.

May 16, 2019 at 3:11 pm #3827321

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

thanks for contacting us.

I would need your WPML debug information. You can find it in:
WPML -> Support -> click on debug information link
Then you can copy/paste the text you see in the Debug box I'll enable for the next answer.
More information here: http://wpml.org/faq/provide-debug-information-faster-support/

Is the page translated? If so, how did you translate it?

May 16, 2019 at 3:12 pm #3827327

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

.

May 17, 2019 at 8:32 am #3832365

carolinev-8

Hi there, I've provided the debug information.

I personally didn't set up the events, but I believe they're first actioned with an automatic translation and then a team member updates them in each language is the translation isn't sufficient. There are separate translations for each event in each language, but English and Dutch aren't showing up at all.

May 17, 2019 at 11:45 am #3834147

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you please make sure of the exact translating procedure?
If the plugin creates a single page for the event, then the whole event is not translated and we need to debug it.
But if you need to add the event to a page/post with a shortcode, then it's another issue. In this case, you should see the translated page but not the section. If the page itself it's not translated, then translating if might fix the issue.

May 20, 2019 at 12:35 pm #3846743

carolinev-8

Hi Laura,

The event is created as a post in German, and then we create the Dutch and English translations by clicking the little edit buttons on the right sidebar and syncing the translations from German to Dutch/English. Each event is listed in a sidebar and full calendar, and should also have its own page. But only the German page shows up. So they are pages, not shortcodes. I've tried not having WPML translate all the info (in the area from the 3rd page of my upload), but that didn't help either. We need to be able to automatically translate the events, but also edit them manually if needed and they each need to show up on their individual page.

Does that help you understand the issue?

You can see our full website here: hidden link

and try to see the events pages in each language, starting from the sidebar on this page: hidden link

Thank you for your help.

May 21, 2019 at 3:33 pm #3856719

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

could you provide credentials so I can better check the issue?
I'll enable a private reply.

May 28, 2019 at 11:19 am #3906089

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

the issue is with the permalinks.

If you open the edit page of hidden link, and then you change language with the top admin bar to English, you'll see the permalink is: hidden link

and this page does exist.
But as you can see if you use the language switcher in the frontend you see hidden link.

To solve this, in WPML -> Settings -> Post Types Translation under Veranstaltungen there is an option, Set different slugs in different languages for Veranstaltungen.
There I changed the English slug from "Veranstaltung @en" to "event" and now the page is working. If you change the Dutch slug to the one you wish to have it should work too. You might have to resave permalinks in Settings -> Permalinks

Let me know if this helps you or if you need further assistance.

May 29, 2019 at 9:40 am #3913981

carolinev-8

Hi Laura,

That was helpful, thank you! The english individual event pages are working now, but Dutch ones aren't working and the calendar page hidden link doesn't show in English OR Dutch. It only works in German and there's no option to switch the language.

I've made a little video (link below) showing you the process that someone would go through to see events (on the calendar or on individual pages) on the website, and the issues they'd encounter. I'm sure there's just some additional settings we need to adjust.

hidden link

Please let me know what you think and if you have any thoughts on how to solve those issues.

I'll make another backup today, so you can go in and look at it personally again if needed.

Thank you again for your help!

May 29, 2019 at 3:08 pm #3916775

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

I'm sorry for the 500 error, when I left the site yesterday everything was working fine.
After watching your video I logged in again to check a few things.

About the calendar page: you don't see it in other languages because it's not translated. If from the front end (when you are logged) you click on "Seite bearbeiten"you'll go to the Calendar edit page and from there you'll see there aren't translations. Create them and you should be fine.

About the blank page in English: yesterday it was working - yes, probably people won't change their language there, but it should work.
The problem, again, is with permalinks. When you try to change language from the event page, the language switcher send you to: hidden link while the correct address is hidden link

About Dutch pages, it's a permalink issue again: as you can see, this page exists: hidden link
but from the site you are going to hidden link

Basically for both English and Dutch you are getting the German post slug instead of the correct ones.
Now I noticed that in Settings -> Permalinks you had selected "custom structure" but there wasn't any structure. I switched it to post name (because that's what you have on the Blog page) and it seems to work now, at least for me.

Please check if it works for you too and if you are meeting further issues.

May 31, 2019 at 1:16 pm #3930805

carolinev-8

Hi Laura,

That's a big improvement, thank you so much for your help!

Everything mostly works, but it's odd - sometimes I still get Server errors on some pages (image attached), but not always on those pages - sometimes they work and sometimes they get a server error (mostly on Dutch pages). Also the language switcher sometimes stops working - there's a little down arrow still, but no languages drop down. Again, not happening often, so I hope it's a wierd caching thing and that people won't need to click around as much as I am anyways.

Maybe the server is having trouble processing so much switching back and forth? I've reset my cache in Safari, but get the same random server errors on Chrome and Safari.

Any ideas on what might cause that? Maybe it'll just go away or won't be an issue for regular viewers? Do you get that error come up at all? I'll ask my client to try the site out as well.

May 31, 2019 at 2:49 pm #3931321

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

when you encounter "random" issues, 90% of the cases they are related to cache or server settings.

You may try to temporarily disable W3 Cache plugin and see if you can still see the issue, or ask your hosting if there is a server cache enabled (it may conflict with the plugin).

If you still meet the 500 server error, you might want to check the server error log, or enable the WordPress debug log. to do it, edit wp-config.php and insert the following lines:

define( 'WP_DEBUG', true );
define( 'WP_DEBUG_LOG', true );
define( 'WP_DEBUG_DISPLAY', false );

Browse to the page with the issue and/or reproduce the issue.

Locate the debug log in: /wp-content/debug.log

Since the main issue is solved, I'd ask you to open a new ticket if you want to further investigate this issue (maybe you can do it once you get a new error, so we can have something to start with). We try to have only one issue per ticket, so it's easier for others to search the forum. This also allows supporters to be faster and more efficient.

June 4, 2019 at 2:02 pm #3952223

carolinev-8

Hi Laura,

I'm still getting the errors despite deactivating W3 Cache Plugin, and we also got an alert from the web admin for the website's university that subpages aren't working. I'll open a new ticket, but I'm sure I'll have to redirect them to this one so they can see what we worked on.

Thank you for your help.

June 4, 2019 at 3:24 pm #3953263

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+02:00)

Hi,

if you want once this ticket is resolved you can assign a new one to me directly. It should give you the option to choose a supporter when you open a ticket.

June 7, 2019 at 11:07 am #3975697

carolinev-8

Hi Laura,

Another WPML support rep found that one of the other plugins was causing the internal server errors. Luckily its not a plugin we need to be activated all the time, so we've deactivated it and the calendar works now to click back and forth, etc.

Unfortunately I've noticed one lagging issue now that the internal server error is fixed. German and English work perfectly for everything, but Dutch only works to see the full calendar (this page: hidden link). If I click on Nieuws and click a specific event from the sidebar, it shows the page could not be found again (like here: hidden link).

I know you said this was all caused by the permalinks, but I'm confused about how to fix it properly. Would you be able to try one more time please?

Thank you again for all your help!

The topic ‘[Closed] All-in-One Timely Events Calendar shows individual events pages only in German’ is closed to new replies.