Please make sure to update to WPML 4.3.4 before reporting any issue

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 39 replies, has 3 voices.

Last updated by Laura 3 months, 1 week ago.

Assigned support staff: Laura.

Author Posts
June 7, 2019 at 12:50 pm #3976389

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I checked your site, and at the moment I have no idea why the permalinks are not working anymore. I even get error 404 on any single event page, but I can see in the admin area they exist. Maybe fixing the other issue triggered this one.

Could you report here your .htaccess file so we can see if there are some hint in there?

June 11, 2019 at 11:43 am #3994829

carolinev-8

Hi Laura,

The plugin that we deactivated to get rid of the Internal Server Errors was WP File Manager. Not sure why deactivating that plugin would cause these errors? I had to reactivate it again in order to access the .htaccess file, but then deactivated it again. I don't have FTP access for this website.

The .htaccess says:

# BEGIN WordPress
<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

# Wordfence WAF
<Files ".user.ini">
<IfModule mod_authz_core.c>
Require all denied
</IfModule>
<IfModule !mod_authz_core.c>
Order deny,allow
Deny from all
</IfModule>
</Files>

# END Wordfence WAF

I've also deactivated W3 Total Cache.

Hopefully this is helpful for you?

Thank you!

June 12, 2019 at 1:41 pm #4004831

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

could you try to disable WordFence too?

June 13, 2019 at 10:37 am #4012013

carolinev-8

Hi Laura,

I have deactivated Wordfence, but still get Page not found on the Dutch pages. I don't get 404 errors though - are you getting actual 404 errors or pages like the one attached?

June 13, 2019 at 3:35 pm #4014697

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

yes, I get a page like that one, it's still a 404. The strange thing is that before if I opened the correct link I got the correct page, now I don't anymore, even if I try to resave link.
At this point I have no more suggestions so I'd like to take a copy of the site and do further tests, if you agree.

June 14, 2019 at 9:23 am #4019839

carolinev-8

Hi Laura, yes we're fine with that option. Please go ahead. I'll make a backup again now just in case.

June 20, 2019 at 12:05 pm #4059775

carolinev-8

Hi Laura,

I've migrated it over now. Sorry for the delay, we usually wait until an email comes through to check the support tickets/messages, but we didn't get one for your last message.

I look forward to your response! Thank you again for your help 🙂

June 21, 2019 at 11:08 am #4066501

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Since Laura currently has a few days off, I will replace her here in the forum. I hope this is OK for you 🙂

I just logged in to the migration resaved the events slug and the single events page sare working properly so could you please check the issue once on the migration site?

Look forward to your reply.

Thanks

June 24, 2019 at 9:40 am #4076073

carolinev-8

Hi Shekhar,

I've checked and there's a lot missing on the migration site, like images and all the events. I can't even see any event listings in the calendar, much less the individual events pages (please see screenshot). Can you send through the URLs that you're referring to that are working?

Thank you.

June 24, 2019 at 11:55 am #4076961

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I was referring to 404 error happening on the single events page, could you please confirm that the 404 error is solved now, once it's solved I will check the events not appearing on the calendar page.

Look forward to your reply.

Thanks

June 25, 2019 at 10:19 am #4083139

carolinev-8

Hi Shakhar,

If I can't see any events in the calendar, I can't click through to see if the 404 error is resolved. So I unfortunately can't confirm that for you.

I noticed just now that this is now ALSO happening on the live site. All events were showing up on the live site last week, with the blank event page errors happening for Dutch and sometimes English. Now even German version doesn't show any events at all. Have you made a change within the live site? I haven't and it was fine last week. I'll have to restore from backup and see if I can get them back on the site.

Please see here - we have plenty of events in the system, but none show up in the sidebar calendar like they used to: hidden link and they're not showing up at all on your test site: hidden link

When will Laura return? She was incredibly helpful at solving our problems and I'd prefer that she handled this issue for us. I don't feel that you're understanding the issue as well as she did.

Thank you.

June 26, 2019 at 12:51 pm #4092583

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

I'm back. Sorry for making you wait, but we need a vacation every now and then 🙂

I checked your site - about the images, it's normal you don't see them as we automatically remove them during migration to reduce the site size.
As for the events, on the copy the latest one recorded is from June 19, so this explains why you don't see them in the copy.

I created a new test event but I got a 404 again.
I disabled all plugins except the WPML and Event calendar and the event was visible again.
Reactivating plugins got error 404, but I tried to see if one of them was causing this and I couldn't find any.
I resaved the permalinks and now the event is visible again.

Probably there is something that triggers changes in how permalinks work, but I'm not sure what. If resaving the permalink solves the issue, this would explain why my colleague didn't manage to see the issue.

Creating a translation instead triggers a 500 error which I still have to check, but I wanted to update you in the meanwhile.

June 28, 2019 at 10:34 am #4106569

Laura
Supporter

Languages: English (English ) Italian (Italiano ) Portuguese (Brazil) (Português )

Timezone: Europe/Rome (GMT+01:00)

Hi,

after some more testing and a brief discussion, we decide to escalate the ticket to the 2nd tier.

I'll update you here as soon as possible.

July 2, 2019 at 6:46 pm #4129505

carolinev-8

Hi Laura,

Thank you for the update!

July 11, 2019 at 12:50 pm #4189883

carolinev-8

Hi Laura,

I'm wondering if there's any update on this issue yet? I'm going on holiday soon and would like to give my client an update before I go.

Thank you!

The topic ‘[Closed] All-in-One Timely Events Calendar shows individual events pages only in German’ is closed to new replies.