This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 1 reply, has 2 voices.

Last updated by Bigul 2 years, 10 months ago.

Assigned support staff: Bigul.

Author Posts
August 31, 2017 at 11:25 pm #1355656

victorH-3

We are getting a bug where loading the translated site give us a long stream of language variables on the URL as seen below:

hidden link

September 1, 2017 at 11:29 am #1355918

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi @victorh-3,

Thank you for contacting the WPML support. We are happy to help you.

May be the issue is happening because you are using an older version of PHP. Please try the following steps after a full site backup and let me know your feedback.

1) Please upgrade PHP version to 5.6, the least required PHP version for WPML is 5.3

https://wpml.org/home/minimum-requirements/

2) Please increase *WP Memory Limit* to *128*(the least required memory limit for WPML) or more. Please check the following link for more details

https://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

3) Please upgrade to the latest version(4.1.2) of Enfold theme. Check this link for more details hidden link

4) Then visit WPML>>Languages, resave *Language URL format* settings

5) Visit Settings>>Permalinks and resave the settings. Then make sure you are still having the issues

If you are still having the issue, please share with me the exact steps to reproduce the issue.

--
With Regards

Bigul

The topic ‘[Closed] All Links getting infinite stream of spanish language variable in the URL’ is closed to new replies.