This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Bobby 1 month, 3 weeks ago.

Assigned support staff: Bobby.

Author Posts
August 15, 2019 at 7:11 pm

Phillip

I am trying to: Translate my entire site.

Link to a page where the issue can be seen: The whole homepage - hidden link

I expected to see: All my sites translated

Instead, I got: All my sites back to basic

August 15, 2019 at 9:22 pm #4403591

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hi There,

thank you for the access details !

i can see that the English language was hidden.

When a language is set to hidden you have to go to User Profile->Edit User Profile-> Enable "display hidden languages "

now i can see your translations as expected, anything that has been translated to English shows in the front end

August 16, 2019 at 6:36 am #4404853

Phillip

Hello,

I already did this. But almost all my translation is gone, they are just back to normal langusge, do you have any idea why?

IT is like when i hit i he save buttons it didn't save...

August 16, 2019 at 7:13 pm #4407967

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

There is a possibility that when you saved the translation you could of encountered an error 500 causing the translations not to save.

at the moment there is no known bug that would cause this behavior , are you able to reproduce the issue on the same page or a new page ?

we could possibly review your debug log to see if any fatal errors were recorded

You can see how to enable debug logging here:
https://wpml.org/documentation/support/debugging-wpml/

Go in your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:
define('WP_DEBUG', true);

Edit your wp-config.php file and add these lines, just before it says 'stop editing here':

ini_set('log_errors',TRUE);
ini_set('error_reporting', E_ALL);
ini_set('error_log', dirname(__FILE__) . '/error_log.txt');

This will create an error_log.txt file in your site's root directory. Please send me its contents.

August 17, 2019 at 11:36 am #4409879

Phillip

Hello, if this is the case:

There is a possibility that when you saved the translation you could of encountered an error 500 causing the translations not to save.

What can i do then? Are they not saved then - am i just fucked?

August 19, 2019 at 5:41 pm #4418065

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

Hello,

did this happen for all pages that the translation existed on ?

or did it happen only when you were working on a specific page's translation and once you clicked the save button then you lost your work and the translation of that page did not save , correct ?

1. are you able to reproduce this behavior with this page again ? (make some test translations )

2. are you able to reproduce this behavior with the rest of the pages ? ( i see most of them are translated sucessfully )

3. are there any errors within your console when saving the page ? (right click => inspect-> console tab on chrome browser)

4. are there any errors within your error log ?

NOTE : if you made translations and the page did not save for any reason causing the translations to be lost then i believe that there is no specific way to get them back as they were never successfully saved

NOTE 2 : i test this with the "Beyond Budgeting" page and it worked as expected ( i duplicated the content of the default language) without getting any errors

August 21, 2019 at 8:59 am #4429231

Phillip

But the problem, is:

1. I translated all the text, and i checked the "translation is complete".
2. Then i log in again som days later, and it is like the translation just copied the original language?

So it makes no sense to me.

August 21, 2019 at 6:24 pm #4434595

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

I understand the problem but i am not able to reproduce it

that does not mean that the problem does not exist on your site but we will need more information so we can better understand what might be going on.

the questions i have asked in my previous thread are important in order to better understand and debug this issue.

1. Were you able to retrieve your error log ? or check within your console for any errors ?

2. Please provide me with a specific page that you have translated at the moment that keeps reverting back to original language.

3. Does this happen with all your pages ?

Additionally i created a test page "WPML Test Dansk" and added a translation to it successfully without it reverting back to the original language yet

August 22, 2019 at 7:52 am #4437369

Phillip

I think you misunderstand me.

This happende like weeks ago, and it seem to work now. But ALL my work is kinda lost....

So is there some way to get it back? Or did i activate somekind of setting that erased it all?

August 22, 2019 at 10:40 pm #4443091

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-07:00)

WPML itself does not have a feature to do this at the moment and the only option that would erase content from WPML's side is within WPML->Support->Troubleshooting->RESET which does not seem to be what happened here as that would of erased all of WPML's information and start fresh

If you have lost your translations or any content the best option here would be to use one of your site's backups

additionally do note that any translations are saved within your database table wp_posts are you able to find your old translations within the database table by any chance ?

The topic ‘[Closed] All my translations are "reset"’ is closed to new replies.