This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 2.68 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem:

Two section of the page does not appear in the translation area. The client is using WPBakery pagebuilder.

Solution:

copy the following code snippet to WPML > Settings > Custom XML Configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_icon</tag>
            <attributes>
                <attribute encoding="vc_link" type="link">link</attribute>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

Relevant Documentation:

https://wpml.org/documentation/support/wpml-integration-with-page-builders-that-use-shortcodes/

This topic contains 3 replies, has 2 voices.

Last updated by yusuf-mertS 4 months, 4 weeks ago.

Assigned support staff: Dennis.

Author Posts
May 23, 2019 at 8:05 am

yusuf-mertS

I am trying to: I want to translate my homepage. But two section of the page does not appear in the translation area. (Image 1) (Image 2)

And this is my translation page scren.

Link to a page where the issue can be seen: hidden link

How can i fix this problem?

May 23, 2019 at 8:41 am
May 23, 2019 at 8:49 am #3872695

yusuf-mertS

I updated wpml-config.xml but it didnt work.

For example i have this shortcodes in my page;

[vc_row][vc_column width="1/1"][vc_icon title="Icon Title" link_text="Link Text"]Icon Text[/vc_icon][/vc_column][/vc_row]

And i added this code to wpml-config.xml;
<shortcode>
<tag>vc_icon</tag>
<attributes>
<attribute>title</attribute>
<attribute>link</attribute>
</attributes>
</shortcode>

May 23, 2019 at 9:14 am #3872825

Dennis
Supporter

Languages: English (English )

Timezone: Asia/Manila (GMT+08:00)

Hi,

Thank you for your reply.

Could you please copy the following code snippet to WPML > Settings > Custom XML Configuration

<wpml-config>
    <shortcodes>
        <shortcode>
            <tag>vc_icon</tag>
            <attributes>
                <attribute encoding="vc_link" type="link">link</attribute>
                <attribute>title</attribute>
            </attributes>
        </shortcode>
    </shortcodes>
</wpml-config>

-clear wordpress cache
-edit the page on the original language.
-make a small change on one of the heading text. click 'Update.
-undo the small change. click 'Update'
-translate the page to secondary languages.

Please let me know how it goes.

Kind regards,
Dennis

May 23, 2019 at 9:25 am #3872899

yusuf-mertS

My issue is resolved now. Thank you!