Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 3 replies, has 2 voices.

Last updated by Bigul 2 months ago.

Assigned support staff: Bigul.

Author Posts
November 21, 2019 at 8:42 pm #4993153

Peter

Hi,

I'm getting 502 errors, when I visit any Russian post or page. It is happening only when I'm logged in. Russian is not the default language and it was working before.

Do you have any idea what should I do? Thank you!

November 23, 2019 at 7:40 am #5002803

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

Please try the following steps and make sure the issue is existing or not.

1) Visit WPML>>Languages>>Language URL format
2) Resave the settings
3) Visit Settings>>Permalinks
4) Resave the settings

If the issue exists, please share with me the WordPress debug.log (not WPML debug information).

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. Please do the steps to reproduce the bug and check you are getting any errors or warning related to WPML in the log file.

If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

November 25, 2019 at 9:12 pm #5017115

Peter

Thank you Bigul for your quick response!

I just found, that it is connected to Views plugin. When I deactivate it, the pages/posts are loading without any problem.

I deleted all views, content templates, archives to see, if any is in conflict, but even there were no views, the pages/posts are not working. They are working only, when I deactivate the plugin.

There are no entries in error log.

November 26, 2019 at 8:00 am #5018767

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. Please try the following troubleshooting steps after a site backup and make sure the issue is existing or not.

1) Go to WPML>>Support page

2) Click on Troubleshooting link (blue link in the middle of the page)

3) In the Troubleshooting page, please click on the following options of the *Clean up* section. Wait for confirmation of processing after each one.

- Clear the cache in WPML
- Remove ghost entries from the translation tables
- Fix element_type collation
- Set language information
- Fix WPML tables collation
- Assign translation status to duplicated content
- Fix terms count
- Fix post type assignment

--
Thanks!

Bigul

The topic ‘[Closed] All posts and pages are giving 502 errors, but only for Russian language.’ is closed to new replies.