This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The user was having issues with images in some languages. the images did not appear Solution: The image were replaced by a base64 code in the erroneous language. The theme had always option Lazy loading On, but it seems after updating the theme it is not working properly. After Disabling Lazy Loading on the theme settings it worked.

This topic contains 13 replies, has 3 voices.

Last updated by khalidf 4 months, 2 weeks ago.

Assigned support staff: Jamal.

Author Posts
May 23, 2019 at 8:13 am #3872417

khalidf

All images do not load for products and pages for 2 languages of the website, while all loading fine on the other 2 languages ...
It is not a server issue ..
I deleted all the images and the posts posted at the same day the could make an issue ..
Disabled and enabled Woo-Muli and it is the same

May 23, 2019 at 10:03 am #3873255

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for contacting WPML support!

Can you tell me what this means?

I deleted all the images and the posts posted at the same day the could make an issue ..

Does it mean that you tried replicating the issue, but it is still there even for new products on these 2 languages?

Can you try the following first:
WPML -> Settings -> Media Translation -> Check all -> Start
https://wpml.org/documentation/getting-started-guide/media-translation/#media-translation-settings

And also this:
WooCommerce -> WooCommerce Multilingual -> Status -> Troubleshooting (lower right) -> Sync products "gallery images" -> Start

Let me know if this resolves the issue.

Regards,
Bruno Kos

May 23, 2019 at 11:50 am #3874817

khalidf

I did your steps and it is the same ...
And yes .. at this day i uploaded some product .. and after while this issue happened ... so i deleted those product with their images to check if they were the reason ... but it is the same .. and at the same day i updated the WPML .. with other couple of plugins .. so i am checking with u because WPML could be the reason for reason .. because it appears in 2 yes and 2 no ... if it was other plugin i think it should not appear for all not only for two lan.

May 23, 2019 at 12:30 pm #3874977

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

In order to debug this issue further quickly, would you be willing to provide me with temporary WordPress admin username so I could investigate the issue directly? I have marked your next reply private so you can safely add this information.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Please make a full backup of your site before sharing this info!

You can use plugins such as UpdraftPlus WordPress Backup Plugin (https://wordpress.org/plugins/updraftplus/) or ask your host to perform a site backup.

Regards,
Bruno Kos

May 24, 2019 at 8:05 am #3882073

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Thank you for the logins, these work - can you tell me the following:
- for which languages this isn't working?
- can you give me 1-2 links of the broken products?

Regards,
Bruno Kos

May 24, 2019 at 2:19 pm #3885557

khalidf

can u give me private please ... i do not want to add puplic

May 24, 2019 at 2:34 pm #3885657

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

Your next reply is private, you can write inside as well.

Regards,
Bruno Kos

May 25, 2019 at 5:19 pm #3889717

khalidf

What is the updates?!!

May 27, 2019 at 6:52 am #3893805

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I wasn't working during the weekend - I am checking through the site and can see that it is not working here: hidden link - which is a home page in a default language. Can you tell me if this is also happening if you temporarily deactivate WPML main plugin?

Regards,
Bruno Kos

May 28, 2019 at 4:40 am #3902703

khalidf

Yes it happens if paused it temporarily

May 28, 2019 at 10:44 am #3905767

Bruno Kos
Supporter

Languages: English (English )

Timezone: Europe/Zagreb (GMT+02:00)

Hi,

I've also checked this scenario - indeed it looks like that images are not loading even if WPML is not active. Therefore, may I ask you to debug this first, as this doesn't seem to be WPML-related issue?

There may be something else blocking your images, things like caching (plugins or server side), incompatibilities with some plugin, theme or something else.

Regards,
Bruno Kos

May 28, 2019 at 12:34 pm #3906897

khalidf

CAn you check this please .. it is related to your plugin i guess

May 29, 2019 at 12:49 pm #3915547

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Please check my previous private message, I made it private to not disclose one screenshot.

Please also, check with your hosting provider to enable the "Multibyte String extension" which is required by WPML. It may be the cause of this issue. See the attached image.
https://wpml.org/home/minimum-requirements/

Best regards,
Jamal

May 30, 2019 at 1:38 am #3919285

khalidf

The theme had always option Lazy loading On, but it seems after updating the theme it is not working properly .. so after i disabled Lazy Loading on the theme setting it worked back perfectly ...
Now it is fine..
Thanks for your help