This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 20 replies, has 3 voices.

Last updated by Ahmed Ibrahim 1 year, 2 months ago.

Assigned support staff: Ahmed Ibrahim.

Author Posts
May 14, 2018 at 4:23 pm #2124473

reiL

I am trying to: Get my products translated and translations uploaded to the site.

Link to a page where the issue can be seen:

I expected to see:my products info translated and uploaded fully to the web

Instead, I got: all the translations came in in an archived file and only some of them were uploaded to the web, the others I had to upload myself one at a time.

Hello,
We are using WPML with Lionbridge translation service for our multisite. We have sent over a big translation Batch, it came back eith all the translations, but only part of them got uploaded to my web automatically. The rest I had to do manually one by one.
After that we have sent test ones with just one product in a bundle - with this everything was just fine - translated and uploaded.

Could you please tell us, why did we experience the issue?
We have sent a pretty big bundle now and are afraid, we could experience the issue again.
Could you please log to our site and check?
what accesses do you need for it?

Thanks a lot!
Reil

May 15, 2018 at 11:21 am #2136972

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

For helping further on this issue it's very important to know your site related information such as themes used, plugins used, PHP versions etc. You can easily send this using Debug information settings from WPML. So could you please go to WPML > Support > Debug Information and give me the information in the next reply. You can read the detailed instruction here: http://wpml.org/faq/provide-debug-information-faster-support/

Have you selected Translation Pickup Mode as "Translation Service will deliver translations automatically using XML-RPC" or "The site will fetch translations manually" If you select this as automatic the translation should be received automatically?

More Details: https://wpml.org/translation-service/lionbridge/#receiving-completed-translations

Look forward to your reply.

Thanks

May 16, 2018 at 2:48 pm #2160015

reiL

Hello Shekhar

Thanks a lot for your answer!
I have included the debug info, you requested.
Concerning your question, yes, we have selected Translation Pickup Mode as "Translation Service will deliver translations automatically using XML-RPC"

I would also like to know, if it is possible to have one of your manager log into our site and check our WPML settings. If it is possible, than how soon it could be done and what accesses do you need for it?

Thanks a lot for your help!
Kind Regards,
Reil

May 16, 2018 at 4:29 pm #2161236

reiL

Hello once again Shekhar.

We have just received that big translations batch, that I mentioned above.
Not all the fields came back translated.

If you look at this product as an example on Taiwan English: M18™ FORCE LOGIC™ 6 Ton Cable Cutter
On the translation page there are 2 sections, "Custom Fields" and "Variations Data"
Both of these have a "Variant Name" field. Under Variations Data it has the English entered with no translation and under Custom Fields it is empty.

Also when I disable the "Variant Name" setting on the Translation Management page both of the "Variant Name" fields disappear (Under Custom Fields and Variations Data) when translating a product.

Could you please check why am I experiencing these issues.
Thanks again!
Best Regards,
Reil

May 17, 2018 at 9:49 am #2172609

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Thank you for contacting WPML support. I'd be happy to assist you further on this issue.

To further debug this issue, I need to request temporary access (wp-admin and FTP) to your site in order to be of better help. You will find the needed fields for this below the comment area when you log in to leave your next reply. hidden link

These info is private, and available to you and supporters only. Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note that:

#1
Backup (both files and database) your site before giving us your credentials. You can use a plugin for this if you like. I often use the Duplicator plugin for this purpose.
See: http://wordpress.org/plugins/duplicator/

Duplicator instruction
hidden link

#2
It would be better if you give me the test site rather than the live site.

#3
If the issues needs some changes in the plugins updates/disabling we will install a plugin called “duplicator” and replicate the site in our local server for testing.

Look forward to your reply.

Thanks

May 18, 2018 at 11:00 am #2188816

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I am discussing this issue with our 2nd tier supporter and will respond to you soon.

Thanks

May 22, 2018 at 7:37 am #2205497

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hi there,

In order to be better help on this issue, I have escalated this issue to our 2nd tier supporter and one of the 2nd tier supporters will respond to you soon.

Thanks

May 22, 2018 at 9:20 am #2206376

reiL

Thank you Shekhar,
I'll be looking forward for your guys responding.

May 23, 2018 at 1:47 pm #2215790

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi, this is Ahmed Ibrahim from the second tier support team.

As I can see that you haven't duplicated your Fields Groups as mentioned on our documentation here: https://wpml.org/documentation/related-projects/translate-sites-built-with-acf/ and instead of that, you have created a new group in the translated language and it is not connected to the original one which is wrong.

So I think if we deleted the fields groups in the secondary language, and then duplicated the original ones, this could help to resolve the issue, so do you have a test site that we can use to test this, if now, please send me your duplicator package and I will test it on my local server, For this, you'll need to temporarily install a plugin called "Duplicator" on your site. This will allow you to create a copy of your site and your content. You can provide me with the snapshot following these directions:
If you already know how Duplicator works ( http://wordpress.org/plugins/duplicator/ ), please skip the following steps and just send me the installer file and the zipped package you downloaded.

:: Duplicator instructions
hidden link

Send me both files (you probably want to use DropBox, Google Drive, or similar services)
#Important:
As the snapshot file will be quite big, you can exclude the images if the file is very big, you can use the filters to exclude the uploads file and also use the filter to exclude any compressed files with these extensions .rar, .gz and .zip )

I will set the next reply as a private reply so you will able to provide a link to download the duplicator package.

Thanks and Best Regards

May 28, 2018 at 8:47 am #2236901

reiL

Hi there Ahmed,

Thank you for your response on this.

My development colleague who has been working on this is out of the office today but he has asked me to get in touch with you in the meantime. He will be back in the office tomorrow.

Can you please message us privately from your end so we can continue the dialog in private? We need that done by you initially so we can move ahead with this conversation securely.

Thank you in advance,
Adrian

May 28, 2018 at 11:44 am #2238149

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I can't set the whole conversation to be private, I only can set the next reply to be private, so I will set it to you as private so you can send me the needed link.

Best Regards.

May 31, 2018 at 7:25 pm #2258411

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

It will be hard to install a multisite manually, it will need a lot of change in the configurations, so please download the duplicator pro from here: ***
and send me the package at the next reply, I have tried to log in to your site to download it my self but it seems to be not available.

Best Regards

June 6, 2018 at 1:36 pm #2283956

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

I have checked the issue and it comes from ACFML and I have reported it to our developers, for now as a workaround, you have to go to WC -> WCML -> settings and choose to use the "Native WooCommerce product editing screen" then to go to the translated product in the normal WC editor and then click the update button, and this should fix the page, as I did here: hidden link

I will update you once I get any new info from the dev team.
Best Regards.

July 17, 2018 at 10:06 am #2529902

reiL

Hi Ahmed,

Can you confirm if there is an update from the development team into this issue?

We have been using the method suggested by you previously of changing to the "Native WooCommerce product editing screen" and then updating the product.

However, this is quite a cumbersome process so wondered if there is an available patch which fixes this?

Thank you in advance,
Adrian

July 17, 2018 at 7:58 pm #2530865

Ahmed Ibrahim
Supporter

Languages: English (English ) Arabic (العربية )

Timezone: Africa/Cairo (GMT+02:00)

Hi,

First thing please update all your WPML plugins to the latest version.

Can you please try to do the following suggestion from the dev team,

- Visit any product at the default language, like here: hidden link
- you will find a section at the end of the page called "Multilingual Content Setup", this section shows you the configuration for your custom fields
- Click the blue link "show system fields".
- It will show you some hidden custom fields starts with "_" like "_doucument_0_title"
- For each system field related to ACF, set to copy its value, then click the "Apply" button at the end of the table.

Note that if you set one system field to be "Copy" in one product, the other products which use the same system field will also copy the same configurations.

You can go to WPML -> Translation Management -> Multilingual Content Setup -> Custom Fields Translation
Or if you updated the plugin, you will need to go to :
WPML -> Settings -> Multilingual Content Setup -> Custom Fields Translation
and then click on the link "show system fields", and you will see all the system fields at your site, and you can set them to be "copy" at this page.

After setting these configurations to be "copy", this should help to resolve your issue, and saving the translation at the WCML editor should be enough to show the fields at the front-end

Please take a complete backup before doing any change, and let me know if that helps you.
Best Regards.