This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 3 replies, has 2 voices.

Last updated by Alejandro 5 months, 2 weeks ago.

Assigned support staff: Alejandro.

Author Posts
May 6, 2019 at 8:58 am #3746087

benoitL-19

Tell us what you are trying to do?
hidden link is redirecting to hidden link

Is there any documentation that you are following?

Is there a similar example that we can see?
all non home url redirect (301) to home url when permalink is set to article name rewrite.
if no rewrite rule is applied no problem every page is accessible

What is the link to your site?

hidden link

May 6, 2019 at 1:08 pm #3748771

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

The problem is coming from your theme.

As soon as i changed the theme, the problem disappeared.

You mention the following:
"all non home url redirect (301) to home url when permalink is set to article name rewrite.
if no rewrite rule is applied no problem every page is accessible"

May i know what do you mean by "if no rewrite rule is applied"?

What rewrite rule are you talking about (there are many in the .htaccess file)?

P.S: I installed 2 plugins needed in order to ensure compatibility between ACF and WPML (Translation Management and ACF Multilingual), you can deactivate them if you believe they are not needed although i encourage you not to do it.

May 6, 2019 at 1:16 pm #3748805

benoitL-19

when i said no rewrite applied i mean in Settings, i let the url to be hidden link.
in original htaccess :

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /fr
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /fr/index.php [L]
</IfModule>

I thought about the WPML because it constraints the french language as the default, from what I know it is not needed. I will try to see how to solve the pb at the theme level, thank you.

May 6, 2019 at 1:30 pm #3748985

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

In fact, you shouldn't really touch anything in your .htaccess because WPML does it for you.

The /fr was not really constraint, it was part of a setting you selected (probably by mistake) but i fixed that (left as it was, would give you redirection loops errors in the future).

The setting i'm talking about is found in WPML > Languages > Language URL Formats (as shown in the screenshot below).

Regards.