Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 8 replies, has 2 voices.

Last updated by Bigul 1 month, 4 weeks ago.

Assigned support staff: Bigul.

Author Posts
September 27, 2019 at 4:06 pm #4655767

sarahE-4

I am trying to: see translated text

Link to a page where the issue can be seen:
hidden link

I expected to see: french body copy

Instead, I got: english body copy

had same problem a few days ago, deleted 'stuck' job in translation management queue.

Tried changing english text to trigger re-translate, but did not work

September 27, 2019 at 7:09 pm #4656483

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve the issue.

This may be a sync issue between the original language page and its translation. Please try the following steps after a full site backup and make sure you are getting the expected result or not.

1) Upgrade to the latest version of WPML(4.2.9)
2) Check the translation status is *Completed* for hidden link page. If not please complete the translation
3) Update hidden link page(just resave)
4) Update hidden link page(just resave)

Please check the following documentation for more details.

https://wpml.org/documentation/plugins-compatibility/how-to-build-multilingual-sites-with-wpbakery-page-builder-and-wpml/

https://wpml.org/documentation/support/maintaining-wpbakery-page-builder-compatibility-with-wpml/

--
Thanks!

Bigul

October 5, 2019 at 2:11 am #4699111
sarahE-4

That did not resolve the issue.

We have been having severe problems trying to use WPML both because of this problem and another which when editing menus, unrelated translated menus become damaged/corrupt and this is happening frequently.

We also tried disabling wpml translation management, and when we create a new translated page, the content and images were NOT copied to the new page, in spite of the setting boxes for doing so being checked.

To facilitate resolving these problems, I have setup a duplicate of the site and prepared credentials for wpml support to use, and will also provide cpanel access so that you can use phpmyadmin . Please contact me directly via email (suteny0r@gmail.com) for the access credentials, and site details.

We are running
PHP 7.3.10
Wordpress 5.2.3 running a theme called Bridge by Qode
We use WPBakery's visual layout editor

Sitepress Version 4.2.9
String translation Version 2.10.7
Translation Management Version 2.8.8

New threads created by Bigul and linked to this one are listed below:

https://wpml.org/forums/topic/unrelated-translated-menus-become-damaged/

October 7, 2019 at 8:45 am #4705631

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. As per our policies support via mail is restricted. Do you need our mail ID for creating a temporary admin account?

I am enabling the private option for the next reply. Please fill the private details fields after a full site backup.

Please check the following links for more details about our private information sharing policies.

https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

hidden link

--
Thanks!

Bigul

October 8, 2019 at 5:39 pm #4717459

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and login information. I can log in to the Cpanel. But the WordPress Dashboard is showing ERROR: Invalid username warning. Please check and let me know your feedback.

--
Thanks!

Bigul

October 8, 2019 at 6:24 pm #4717619

sarahE-4

Try it again.
I refreshed the copy of our primary site and forgot to re-create the login for you. It works now

October 9, 2019 at 12:19 pm #4722675

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates and I can log in to the site now. Please check the hidden link page it is showing the translation after the following steps.

1) Update the original language page after a minor edit
2) It helps to refresh the translation settings
3) Update the translation from Classical Translation Editor -hidden link

But I can see a duplication for the contents in Translation Editor. Both entries are translated now. Please check the attached images. Have you noticed it before?

Please note, I have opened a new ticket for the Menu Translation issue. Because as per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket. I will get back to you soon on the new ticket. Please wait. Thank you for your understanding.

--
Thanks!

Bigul

October 13, 2019 at 1:39 am #4743383

sarahE-4

We have followed your workaround previously, sometimes it works, but usually it doesn't

What do you attribute the duplication of the section of text to?

also, previously, a support rep has had me look for 'stuck' jobs in the translation queue, but I don't really understand what that is ( I know where the tab is to display it). Often, the translation that is failing to work does not even appear in that queue

What is the purpose of the queue?

What circumstances cause translations to appear in it?

What circumstances remove items from it?

October 14, 2019 at 8:58 am #4748251

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. The Duplication of *vc_column_text* element string happens rarely. Maybe because of the change in the Database records. It requires further debugging to track the issue.

Please share the URL of the WPML Support ticket for a better understanding of the following issue.

also, previously, a support rep has had me look for 'stuck' jobs in the translation queue, but I don't really understand what that is ( I know where the tab is to display it). Often, the translation that is failing to work does not even appear in that queue

Hope you are mentioning about WPML>>Translation Management>>Translation Jobs or WPML>>Translations queue.

When we are translating a Post or Page a translation job will be created for the translation management of the task. We can find this record in WPML>>Translation Management>>Translation Jobs.

WPML has features to choose a translator or translation service for translating a Post or Page. As a translator, we can find the assigned jobs in WPML>>Translations queue. From there we can translate post/page using WPML Translation Editor.

We can delete or cancel a translation job if a translation is not finished yet. Normally we will not remove the translation job. Only if we want to cancel that job.

Please check the following documentation for more details and let me know your feedback.

https://wpml.org/documentation/translating-your-contents/

https://wpml.org/documentation/translating-your-contents/working-with-translation-managers/

--
Thanks!

Bigul

The topic ‘[Closed] All "vc_column_text: content" parts are not showing the entered translation’ is closed to new replies.