This thread is resolved. Here is a description of the problem and solution.

Problem:

I can't register WPML. It tells me "invalid site key".

Solution:

The client generated a new site key for "www.sitename.com" while his website's link was "https://www.sitename.com" ("https://" was missing) so just creating a new key with the correct complete link made things work.

Relevant Documentation: https://wpml.org/faq/install-wpml/#register

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 3 voices.

Last updated by samanthaB-6 1 year, 8 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
September 26, 2018 at 4:16 am #2765932

Alfons

Tell us what you are trying to do?
put a new site key to a registered site, but cannot validate the key

Is there any documentation that you are following?
attached

Is there a similar example that we can see?
have no idea

What is the link to your site?
hidden link

September 26, 2018 at 8:37 am #2766478

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Please follow the next steps:

1. Go to your WPML.org account once again (https://wpml.org/account/sites)
2. Click "Add new site"
3. Use this link: hidden link
4. Click "Add"
5. Now copy-paste the new key that's generated and try adding it on your site's backend

Please let me know if this worked for you.

September 26, 2018 at 4:16 pm #2768072

Alfons

Hi, Thanks for helping me... already follow your instructions and it's working.
But now I have another issue with the update WPML to the latest version.

see attached file

September 26, 2018 at 7:13 pm #2768461

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi there, I'm glad to hear that the issue is solved.

As the original issue is resolved may I kindly ask you to please open a new ticket for your additional question?

This will help other users with similar problems to find solutions when searching the forum.

Kind regards,

Mihai

October 22, 2018 at 1:17 pm #2838190

samanthaB-6

I need help with this issue too.