This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 4 replies, has 2 voices.

Last updated by Bigul 3 weeks, 2 days ago.

Assigned support staff: Bigul.

Author Posts
September 14, 2019 at 2:16 pm #4572793

oniR

Hello, I've update my plugins yesterday morning and have the exact same issue

Very blocking to create new woocommerce orders, it keeps crashing.

An error of type E_ERROR was caused in line 7 of the file /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/admin/class-wpml-admin-url.php. Error message: Uncaught Error: Class 'WPML_Translation_Management' not found in /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/utilities/admin/class-wpml-admin-url.php:7
Stack trace:
#0 /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/commands/class-wpml-upgrade-display-mode-for-posts.php(83): WPML_Admin_URL::multilingual_setup(7)
#1 /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/commands/class-wpml-upgrade-display-mode-for-posts.php(29): WPML_Upgrade_Display_Mode_For_Posts->get_notice_content()
#2 /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/class-wpml-upgrade.php(146): WPML_Upgrade_Display_Mode_For_Posts->run_admin()
#3 /home/zengarde/public_html/wp-content/plugins/sitepress-multilingual-cms/classes/upgrade/class-wpml-upgrade.php(134): WPML_Upgrade->maybe_run_admin(Object(WPML_Upgrade_Display_Mode_For_Posts))
#4 /home/zengarde/public_html/wp-content/plugins/sitepre

September 14, 2019 at 2:46 pm #4572809

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues.

Hope the issue is happened just after upgrading WPML from 4.2.7 to 4.2.8 version. Please deactivate WPML Translation Management plugin for a moment and check the bug is existing or not.

Please share with me the WordPress debug.log to get more information about the error and warnings.

Please check this page for instructions https://wpml.org/documentation/support/debugging-wpml/

To enable it, open your wp-config.php file and look for define(‘WP_DEBUG’, false);. Change it to:

// Enable WP_DEBUG mode
define( 'WP_DEBUG', true );
 
// Enable Debug logging to the /wp-content/debug.log file
define( 'WP_DEBUG_LOG', true );
 
// Disable display of errors and warnings 
define( 'WP_DEBUG_DISPLAY', false );
@ini_set( 'display_errors', 0 );

// Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
define( 'SCRIPT_DEBUG', true );

In this case, the errors will be saved to a debug.log log file inside the */wp-content/* directory. If you can paste your debug.log to http://pastebin.com/index.php and provide me that link it would be great! (This is the cleanest way because sometimes the logs are long and create a complete mess of discussion).

--
Thanks!

Bigul

September 19, 2019 at 2:30 am #4600667

oniR

Hello

This is the content of the log
https://pastebin.com/LuBtfq4K
I have another ticket open that have mentioned some other users have this problem and asked me to wait for a release. I send the log anyway in case it helps.

Do you have any idea of when a new release will be available to resolve it. It's almost impossible to make any change in the wp-admin pannel as the bug is apppearing very very often

September 19, 2019 at 1:49 pm #4605665

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the feedback and debug.log details. This bug will be fixed in WPML 4.2.9 and it is in QA stage now. So we have a workaround for the issue. This error is happening because of a misconfiguration in the database settings.

Please try the following steps after <strrong>a full site backup</strrong> and make sure the issue is existing or not.

1) Add the following code in functions.php of your theme

add_action('wp', function (){
   $wpml_settings = get_option('icl_sitepress_settings');
   
   if (!empty($wpml_settings['show_untranslated_blog_posts'])) {
       unset($wpml_settings['show_untranslated_blog_posts']);
       update_option('icl_sitepress_settings', $wpml_settings);
   }
});

2) Visit the frontend of the site

3) Remove the newly added code from the functions.php file

--
Thanks!

Bigul

September 24, 2019 at 7:58 am #4628773

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, we have released a new version of WPML 4.2.9 now. It has included the fix for this bug. Please upgrade to the latest version after a full site backup and make sure the bug is existing or not.

--
Thanks!

Bigul