Please make sure to update to WPML 4.3.5 and check our list of Known Issues before reporting

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 3 voices.

Last updated by Kresimir 2 weeks, 6 days ago.

Assigned support staff: Andreas W..

Author Posts
November 7, 2019 at 2:38 pm #4906927

Kresimir

Greetings,

I am trying to show product attribute 'language' on cart page.
I expected to see when I switch language translated product attributes.
Instead, I got not translated language attribute.
If I switch language from one to another attributes remain untranslated. However, if I refresh the cart page, the attributes are translated.
I switch theme to Twenty Nineteen and left only the required plugins on.

Link to a page where the issue can be seen: hidden link .
First you need to add the product to your cart, then go to the card page.

November 8, 2019 at 2:43 pm #4914171

SergeyR
Supporter

Hello Kresimir,
Thanks for reporting this!

Can you please provide access to your site in private form? It will help us to debug a problem in proper way.

Thanks in advance!

November 10, 2019 at 4:41 pm #4921047

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

November 13, 2019 at 3:59 am #4935657

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am writing to you to let you know that I am investigating the issue and I did not find the cause of the issue so far.

For some reason, the attribute "Croatian" is getting registered twice.

I will keep debugging tomorrow and contact you as soon as I have news.

I hope for your understanding and thank you for your patience.

Kind regards
Andreas

November 13, 2019 at 1:19 pm #4939443

Kresimir

Hello,

Take as much time as you need.
Let me know if you found out anything.

Kind regards

November 14, 2019 at 3:40 pm #4948367

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Please have a look at the screenshots.

It seems to be that the issue occurs because of the attribute "Croatian" was created twice.

Could you please try to sort this out then delete the attribute to test if the issue persists?

Kind regards
Andreas

November 15, 2019 at 12:00 pm #4953599

Kresimir

Hi,

I did what you told me. But I think I still have a problem.

New test:
I have made a test product called 'testi product'. I have added one attribute to the testi product called 'Product languages' and assigned him term English.
In my code I get attributes by $item_data->get_attributes(). I left the result on cart page by one function var_dump($item_data->get_attributes()).

English term id => 66
Engleski term id => 72

So, when I'm on cart page on english language, my product have term called English with id => 66. When I switch language to Croatian, my product have the same term id. After I refresh the page the term is finally changes to Engleski with id => 72

Kind regards

November 15, 2019 at 11:04 pm #4957137

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

The access to your staging is sadly not valid anymore.

Could you please recreate the issue on this test-site and let me know if you experience the same problem?

One-Click Login: hidden link

Let me know about the outcome.

Kind regards
Andreas

November 18, 2019 at 9:00 am #4963191

Kresimir

Grettings,

We have one little problem. When I could recreate my problem on your site I should approach your server through SFTP and submit my code. Otherwise, I can't test.
Can you please try again login into my site with credentials I gave you, link hidden link.
Can you try recreate my problem on my site, or can you give me SFTP credentials for your server so I can recreate the problem.

Kind regards

November 18, 2019 at 3:37 pm #4966451

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I am sorry for the inconvenience but may I ask which code you are referring to? Did you include any custom coding on your site? If so, please take note that we can not provide support in such cases.

Our test site uses the same theme as on your staging, as also WooCommerce and the WPML plugins in the latest version.

You can find all the credentials on the dashboard section called WP-Sandbox:

One-Click Login:hidden link
Username:demo
Password:M22YbsZ3Nvf1

SFTP Credentials
Server:w6.wpsandbox.pro
Username:silly-quail
Password:oa960hVU67wZmXOa16NbMWc6
Port:2222

If the same issue will not occur on a new install which for I ask you to provide detailed information about when the issue occurred and which changes have been taken earlier to that.

Kind regards
Andreas

November 19, 2019 at 4:03 pm #4974097

Kresimir

My issue is resolved now. Thank you!