This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: On my website I have a 2 languages. Dutch (primary lang.) & French (secondary lang.)

On the dutch menu, everything works fine.

On the French however I have some troubles. When I click on a tab forexample 'qui sommes-nous' it redirects me to the primary language (dutch) homepage.

Solution: I edited the French version of the page and added the ID in French (qui sommes-nous) that was missing and then fixed the URL in the custom link on the Menu.

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 1 month, 1 week ago.

Assigned support staff: Carlos Rojas.

Author Posts
September 5, 2019 at 3:29 pm #4520577

alecM

Hello,

I just had contact with some one about a problem but It's not resolved yet...
I will make my ticket as detailed as possible:

My website link: hidden link

On my website I have a 2 languages. Dutch (primary lang.) & French (secondary lang.)

On the dutch menu, everything works fine.

On the French however I have some troubles. When I click on a tab forexample 'qui sommes-nous' it redirects me to the primary language (dutch) homepage.

- I have sync'd everything that was proposed on the documentation but still not working.
- I have looked at other tickets and found some people had the same questions so I followed their ticket (changing the permalink and the postname like: website.com/fr/#anchor) but it still did not work.
- I tried making a different menu but that's not the best solution because the menu changes.

Hopefully you can help me?

September 6, 2019 at 8:26 am #4524035

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

1.- I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

2.- Please provide the debug information of the site. In this link you will find the steps to follow: https://wpml.org/faq/provide-debug-information-faster-support/

Kind regards,
Carlos

September 6, 2019 at 10:08 am #4524699

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the information provided.

I edited the French version of the page and added the ID in French (qui sommes-nous) that was missing and then fixed the URL in the custom link on the Menu.

Could you confirm that the issue is solved?

Regards,
Carlos

September 6, 2019 at 10:12 am #4524713

alecM

Thanks Carlos! You've been a great help!

September 6, 2019 at 10:13 am #4524715

alecM

My issue is resolved now. Thank you!

September 9, 2019 at 9:36 am #4535375

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos