This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by mitjaK 5 months, 3 weeks ago.

Assigned support staff: Marcel.

Author Posts
April 9, 2019 at 8:00 am #3563921

mitjaK

Hello,

Thank you for getting back to me, and sorry for the late reply. I saw that you came out with an update for the plugins, and wanted to do that first before trying to fix the original issue. But now I get the message that I need to register when I wish to update. If I try to copy my licence key I get the notice that it is invalid, even though I have a valid licence and it is the only site I use WPML for. If I delete my site in the control panel, then register it again, the new key doesn't work either. Any idea how I could sort this out first? 🙂

Thanks for your help!

Kind regards,

Mitja

April 9, 2019 at 8:07 am #3563973

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi again Mitja,

#1 Could you please send me a screenshot from https://wpml.org/account/sites/
#2 Please send me also the API key you used
#3 I would also need to request temporary access (WP-Admin and FTP) to your site

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Best Marcel

April 9, 2019 at 10:48 am #3565571

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mitja,

Thank you. I would need to test this on the live site, as the installer refers to this URL. I can't check this on a Sandbox or Cloudways copy, as the registration URL would be different.

We can try the following without site access:

- Did you now save on your site the entered API key with the blue "OK" button? What do you see after?
- Can you try a manual update? You can download the files here https://wpml.org/account/downloads/.

No translation & settings will be lost during this process, but I recommend doing a backup before to be 100% save.

Kind Regards
Marcel

April 16, 2019 at 9:37 am #3620497

mitjaK

Hello Marcel,

Thank you for getting back, and sorry for the late answer. Unfortunately the problem still persists. If I copy the key, and click on the blue button "OK" I get the message that was also visible on the print screen: Invalid site key for the current site. Please note that the site key is case sensitive.

As for manually installing updates: I downloaded and tried to install but I get the message that folder already exists and installation fails. Do I need to first delete / deactivate the plug-in...? Wont the translation get lost like that...?

Maybe then the best is indeed to send you a link for a temporary log-in access...? Where can I send it to?

Kind regards,

Mitja

Thank

April 16, 2019 at 2:23 pm #3622925

Marcel
Supporter

Languages: English (English ) German (Deutsch )

Timezone: Europe/Madrid (GMT+02:00)

Hi Mitja,

Thank you for your reply. Yes, you need to delete the folder before.

Don't worry there will be no translations/setting get lost during this process. Please send me your login details, and I will be happy to assist you in this case 🙂

I would need to request temporary access (WP-Admin and FTP) to your site
– preferably to a test site where the problem has been replicated if possible –
in order to be of better help and check if some configurations might need to be changed

Your next answer will be private which means only you and I have access to it.

❌ Please backup your database and website ❌

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

✙ Please add your used site key from https://wpml.org/account/sites/

Thank you

Best Marcel

April 24, 2019 at 9:01 am #3670763

mitjaK

Hello Marcel,

I am sending you a temporary log-in link and would appreciate your help with looking around and trying to fix the issue, which persists after several core plug-in (eg. WooCommerce) and theme updates as well. My key is: ..... In case you need, feel free to de-activate and activate plug-ins, we have a back up from last night.

Another idea i that we have changed hosting service recently - can it be causing the problem in any way?

Thank you for your help once again.

Kind regards,

Mitja

Ps. I have provided, but I needed to delete the link and credentials since it doesnt seem like a private message to me.

The topic ‘[Closed] API key problem’ is closed to new replies.