This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Raja Mohammed 3 months, 1 week ago.

Assigned support staff: Raja Mohammed.

Author Posts
July 6, 2019 at 10:31 am

christianH-80

I am trying to:
For SEO purposes I use Ryte. I got a lot of 404 broken pages errors on categories and tags taxonomy sites (please see attachment).
It seems, that WPML is adding the language shortcodes (de, en) at the end of categories and tags. How I can prevent doing this?

Link to a page where the issue can be seen:
For categories, e.g.
hidden link
For tags, e.g.
hidden link

I expected to see:
For categories, e.g.
hidden link
For tags, e.g.
hidden link

Instead, I got:
404 errors.

July 8, 2019 at 11:39 am #4162019

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi there,

I will help you with your issue.

I am not sure the issue is related to WPML or conflict with any of the plugin, Can you please explain how or from where you got the urls with language code attached at the end (hidden link)

If that is the output of Ryte, I would suggest testing your site with Google Webmaster tools for more appropriate output. Do you get the same results with Google tools?
It seems you have Yoast, Please confirm whether the broken URL appear in the Yoast site map.

If this is the case with Ryte then probably this is a compatibility issue. that needs to be checked further.

Let me know the results.

Kind regards
Raja

July 8, 2019 at 4:31 pm #4164341

christianH-80

Hi Raja,

Well, Ryte does not create these entries.

I get the same error e.g. in Sistrix (see attachment).

In Yoast I disabled category and tags index. Therefore it does not appear in the sitemaps:
hidden link
hidden link

Kind regards

July 8, 2019 at 4:32 pm #4164367

christianH-80

Sorry, clicked to quickly on submit.

PFA Yoast taxonomy disabled.

Please advise...

July 9, 2019 at 4:30 am #4167465

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your information.

Honestly, I'm not sure how sistrix and Ryte work, We generally recommend webmaster tools of Google and Bing in case of any abnormalities in SEO and indexing.

I would request you a few more information

- If taxonomy indexing is disabled in Yoast how the service like Ryte and Sistrix able to index those pages?

- Is it possible for you to fetch the source of the URL, Boken link is often identified with the source. I have inspected your page source I don't see any abnormal results for the categories and tags

- I would request you consider using Google webmaster tools and compare the results with the SEO services.

With detailed information i can check this furhter with the second tier if needed.

Please let me know the details.

Kind regards
Raja

July 9, 2019 at 5:51 pm #4173569

christianH-80

Hi Raja,

PFA a screenshot of Google Search console for the URL:
hidden link

But what in particular do you want to see?
Somehow these URLs are generated...

- If taxonomy indexing is disabled in Yoast how the service like Ryte and Sistrix able to index those pages?
Well, I don't know... Maybe it is generated by WPML. Ryte and Sistrix are crawling the website, even without the sitemaps and indexing...

- Is it possible for you to fetch the source of the URL, Boken link is often identified with the source. I have inspected your page source I don't see any abnormal results for the categories and tags
Source is - according to Google: hidden link

Or for hidden link it is hidden link .

Kind regards

July 10, 2019 at 5:40 am #4176193

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the detailed information, I have checked the site and reproduced the issue. for your referece, I have attached the screenshot, However, inspecting the page source didn't reveal anything.

I have requested the second tier of supporters for a detailed look into the issue. I will keep you posted once I receive an update.

Kind regards
Raja

July 10, 2019 at 10:30 am #4178663

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hi,

Our second tier support sumit found the issue with the pages. On the archive pages, the Social Media widget the third icon has the link herf=”de” which is pointing to hidden link.

I would suggest removing the third social media icon which has just the language code in the href source.

Kind regards
Raja

July 11, 2019 at 2:58 pm #4191207

christianH-80

Hi Raja,

Thanks a lot for the investiation!
Well, I asked the theme provider Shufflehound for the reason.
And they say, it is because of WPML...
hidden link

Any ideas?

Thanks in advance.

Kind regards.

July 12, 2019 at 6:56 am #4195619

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information,

I have checked your site again, The Social media widgets section has a field which retrieves the WPML language selected from the dropdown (Display in language )This functionality is not from WPML and happens only with the "Shufflesound Social widget" (screenshot attached)

This could possibly a compatibility issue WPML and Javelin theme, I can confirm the theme is not in our compatibility list. I would suggest reporting the issue to the theme author. I hope there is no custom code added from your end.

I hope this helps you better.thanks for your patience 🙂

Kind regards
Raja