We have just released WPML 4.3.3. Before reporting issues please make sure to update - this version resolves all known issues with the major WPML 4.3 release

Hi, Amit here, I am the WPML Support Manager, our current ticket queue is high, update your WPML plugins and make sure you meet the minimal requirements for running WPML before reporting an issue please - many tickets are resolved doing that

Please look at our updated list of Known Issues and you can also use our support search to find helpful information and of course review our documentation before opening a ticket.

If you do need to open a ticket please make sure to provide us with all the needed information as described in this page

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:Arabic as second language homepage on a mobile device issue

Solution:SiteGround plugin was causing a 301 redirection

Relevant Documentation:

This topic contains 16 replies, has 2 voices.

Last updated by ahmedM-19 6 months, 4 weeks ago.

Assigned support staff: Bobby.

Author Posts
April 18, 2019 at 2:03 am #3635359

Bobby
Supporter

Languages: English (English )

Timezone: America/Los_Angeles (GMT-08:00)

As your host provider mentioned your .htaccess has a rewrite in it (/en/) causing issues

This issue is a known one and outlined here and why it happens along with a solution to it.
=> => https://wpml.org/errata/htaccess-is-rewritten-with-language-folder/

in order to resolve it i went to wp-content/themes/wyzi-business-finder-child/functions.php and added on line 61 (you can see in the screenshot ) the code to prevent the rewrite in your htaccess file.

your htaccess file no longer has rewrites.

Yesterday when i test it on the mobile it worked as expected but today it did not.

In Summary there seems to be 2 issues.

1. rewrites in your .htaccess
-> This was resolved by following the steps mentioned in the above documentation

2. Redirection to hidden link

The issue here is that there is a redirection on felguide.com/ar/home to felguide.com/ar/ therefore this enters into a loop which crashes on the cellphone.

this is most likely caused on a server level , or through a 3rd party plugin.

as a test i deactivated SiteGround plugin and it seems to be working as expected now.

let me know your results please

hidden link

HTTP/1.1 301 Moved Permanently
Server: nginx
Date: Thu, 18 Apr 2019 01:57:23 GMT
Content-Type: text/html; charset=UTF-8
Transfer-Encoding: chunked
Connection: keep-alive
Expires: Thu, 19 Nov 1981 08:52:00 GMT
Cache-Control: no-store, no-cache, must-revalidate
Pragma: no-cache
X-Cache-Enabled: True
X-Redirect-By: WordPress
Set-Cookie: PHPSESSID=0d14ab7359c11cefba11ed3064931f4d; path=/
Set-Cookie: wpSGCacheBypass=0; expires=Thu, 18-Apr-2019 00:57:22 GMT; Max-Age=0; path=/
Set-Cookie: _wcmp_user_cookie_0=wcmp_cookie5cb7d982e51ce; expires=Fri, 17-Apr-2020 01:57:22 GMT; Max-Age=31536000; path=/; secure
Set-Cookie: pmpro_visit=1; path=/
Location: hidden link
Host-Header: 192fc2e7e50945beb8231a492d6a8024
X-Proxy-Cache: MISS
alt-svc: quic=":443"; ma=86400; v="43,39"

hidden link

April 19, 2019 at 5:16 am #3643655

ahmedM-19

My issue is resolved now. Thank you!