This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 10 replies, has 2 voices.

Last updated by Shekhar Bhandari 4 months ago.

Assigned support staff: Shekhar Bhandari.

Author Posts
June 11, 2019 at 7:29 pm #3998249

jamshidN

My site has both Arabic and English. My theme supports RTL. The current home page is built using visual composer. I have translated all content on this page to Arabic and translation is now 100% complete.

However, when I load the page in Arabic, I don't see any content - I see only the navigation menu. What am I missing. Where did I go wrong? Please help.

June 12, 2019 at 3:40 am #3999861

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Welcome to WPML support. I'd be assisting you further on this issue.

Are the translations marked as "Translation is complete"? Could you please attach a screenshot of the translation editor where the translation is done?

Further, Can you confirm that you are still experiencing issues with minimal set up (all plugins except WPML disabled and the theme on a WordPress default such as Twenty Nineteen)

Look forward to your reply.

Thanks

June 12, 2019 at 5:50 pm #4006605

jamshidN

Translation is 100% complete. Please see screenshot.

Changing the theme to Twenty Nineteen is not feasible as it is live site. And I need the website with both wpml & WPBakery page builder. I can share credentials so that you could access it and help with solving this.

June 13, 2019 at 3:39 am #4009087

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Sure, to debug this issue further, I would need to check your site settings once, for this I would need temporary access (wp-admin and ftp) to your site.

So could you please provide me those details, you will find the needed fields for this below the comment area when you log in to leave your next reply.
hidden link

This info is private and available to you and WPML supporters only.
Read more about this: https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

Note:
Backup your sites before providing the credentials or if possible provide credentials for the test site

Look forward to your reply.

Thanks

June 13, 2019 at 11:47 am #4012455

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

Please follow the below steps to fix the issue:
- Go to Page Editor of the homepage
- On the bottom of the page go to "Multilingual content setup" tab
- Mark the following fields as copy and click on apply.
- Update the post

Fields
imperio_enable_custom_header_options_value
parallaxEffect_value
homeYoutubeLink_value
homeVideoControls_value
homeVideoMuted_value
introLogo_value
introCaptionsEnable_value
introContinueEnable_value
homeStyle_value

Let me know if this helps also, may I kindly ask you please to open a new ticket for your additional question? As per our support policies, we can only handle one issue per ticket. It will help us to serve you better and we can avoid discussing multiple problems in one ticket.

Thanks

June 13, 2019 at 2:17 pm #4013553

jamshidN

Thank you! Most of the content has loaded. Now the YouTube video is not loading. Also, the twitter tweets at the bottom of the page and the copyright content at the bottom are still not loading.

Could you pls help with this.

June 14, 2019 at 3:59 am #4018283

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see that you haven't marked the fields as mentioned in the previous reply, please follow the steps as mentioned and it will fix the issue.

For the twitter issue, how its the tweets added there? could you please let me know.

Thanks

June 15, 2019 at 11:03 am #4026693

jamshidN

I tried doing that, but the options returns back to the same settings. Is there something I'm doing wrong. Could you pls help em with this. Or could you pls do the changes. I give you full authority to.

June 17, 2019 at 3:34 am #4031943

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I just performed the steps and it's working properly now, could you please confirm?

Look forward to your reply.

Thanks

June 17, 2019 at 11:15 am #4034865

jamshidN

It works fine now. Thanks. However, the twitter feed is still not showing up. It comes from [UPPER] Twitter Scroller under UPPER shortcodes in visual composer.

Please help

June 18, 2019 at 3:49 am #4040023

Shekhar Bhandari
Supporter

Languages: English (English )

Timezone: Asia/Kathmandu (GMT+05:45)

Hello there,

I can see the twitter content is there but it's not displaying properly. It looks like the slider is not compatible with RTL languages, could you please contact the author that created the twitter slider and ask if they support RTL languages.

You can also disable WPML once and see if the slider works properly with RTL languages.

Let me know if this helps.

Thanks

The topic ‘[Closed] Arabic content not showing’ is closed to new replies.