This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The site contains pages with all of them translated in all 3 languages. English is the main language the pages are built in, on the row with the Swedish translation they are marked with pencils but all Arabic ones with gear-icons. When I select Arabic in the top row menu (in the WP-admin) no pages are shown in the list of pages. When in the Arabic mode, if I create a new page there and then translate it to English, that new page does not show up in the English page-list. And when you are using the site and select Arabic it jumps back to the english site.

Solution: I have applied some troubleshooting options in the site and after visiting the pages I noticed that none of them are fully translated to Arabic, that's why you can't see any page in Arabic yet.

I created a test page so you can see that the site is working correctly

Relevant Documentation:

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 3 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
July 9, 2019 at 12:54 pm

andreasD-34

Hi!

I have a site that is going to be in 3 languages: English, Swedish and Arabic

The site contains pages with all of them translated in all 3 languages. English is the main language the pages are built in, on the row with the Swedish translation they are marked with pencils but all Arabic ones with gear-icons. When I select Arabic in the top row menu (in the WP-admin) no pages are shown in the list of pages. When in the Arabic mode, if I create a new page there and then translate it to English, that new page does not show up in the English page-list. And when you are using the site and select Arabic it jumps back to the english site.

I have tried troubleshooting this for a while now and noticed that if I create posts that I translate to Arabic, then they show up in the posts list when Arabic is selected. So this seems to be something just happening to the pages section.

Please get back to me if you have any thought.

July 9, 2019 at 8:32 pm #4174283

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I kindly ask you to update all outdated plugins in the site, specially WPML plugins, to their latest version and double check if the issue persists. Outdated functionalities can cause conflicts in the code.

Kind regards,
Carlos

July 10, 2019 at 4:04 am #4175923

andreasD-34

I have updated all plugins (inkl the WPML ones), but the issue is still the same. Have also tried disabling/enabling individual plugins to see if it starts working, but that does not help either. What else can we look at?

July 10, 2019 at 9:38 am #4177839

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your message.

I have applied some troubleshooting options in the site and after visiting the pages I noticed that none of them are fully translated to Arabic, that's why you can't see any page in Arabic yet.

I created a test page so you can see that the site is working correctly: hidden link

Please finish the translation to Arabic and the issue will be solved.
Regards,
Carlos

July 10, 2019 at 10:19 am #4178563

andreasD-34

Now it seems to work fine. Thanks for the quick responses!

July 10, 2019 at 10:24 am #4178613

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos