This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem:

The following error showed in the debug log.

PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/wp-blogs.php on line 3

Solution:

It is not certain what caused this error to show. I suspected that there was a corrupted file in WPML installation. Deactivating and deleting the WPML and then installing a fresh version of it probably solved the issue.

1. Take a full backup of your site in case something goes wrong.

2. Deactivate WPML Multilingual CMS plugin.

3. Delete the plugin.

4. Download the plugin from here https://wpml.org/account/downloads/

5. Upload it to the plugins section on your site and install and activate it.

This topic contains 3 replies, has 2 voices.

Last updated by davidF-64 1 month, 4 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 21, 2019 at 3:36 pm #4433317

davidF-64

Tell us what you are trying to do?
The following 2 error messages appeared in our logs yesterday;
[Wed Aug 21 13:19:26.235168 2019] [:error] [pid 60732] [client 40.117.188.107:32946] PHP Warning: array_key_exists() expects parameter 2 to be array, null given in /var/www/pfi/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/wp-blogs.php on line 3
[Wed Aug 21 13:19:26.235186 2019] [:error] [pid 60732] [client 40.117.188.107:32946] PHP Notice: Undefined variable: l1TXY in /var/www/pfi/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/wp-blogs.php on line 3

Although they do not appear to affect site perfomance or functionality, I would like to find the cause a resolve them.

What is the link to your site?
http:processfusion.com

August 21, 2019 at 5:55 pm #4434369

davidF-64

Hi Itamar,

I have updated the WP memory limit for 4 of our production sites using WPML although this particular error only triggers the processfusion.com site and that did not have an impact on the error. Following that I've activated the ACFML (we hd it installed but not activated) and the errors are still present. Please advise on next steps to resolve this error.

As a side note, is there any way we can have support ticket notification emails sent to a seperate email instead of the default profile email? That would be great if this could be done.

Thank you,
Mario

August 22, 2019 at 12:38 pm #4439391

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi and thanks for trying my suggestions.

When I carefully examine the error, I can see that it points to this path.
/wp-content/plugins/sitepress-multilingual-cms/classes/action-filter-loader/wp-blogs.php on line 3
This weird, because when I check the latest WPML version, I do not see the wp-blogs.php in this location. In fact, I don't think that this file exists in WPML's files system. Or even in WordPress's file system.
When you check this location can you see the wp-blogs.php file there?

Maybe something got corrupted with your WPML installation. Can you please manually replace the current WPML plugin that you use with a fresh copy that you can download from here?
https://wpml.org/account/downloads/
You would need to do the following.
1. Take a full backup of your site in case something goes wrong.
2. Deactivate WPML Multilingual CMS plugin.
3. Delete the plugin.
4. Download the plugin from here https://wpml.org/account/downloads/
5. Upload it to the plugins section on your site and install and activate it.
Does the error keep showing after that as well?

I'm sorry, but I can't send a notification to another email other than the one that is registered on your account. You can change the email of your account here.
https://wpml.org/account/account-settings/

Regards,
Itamar.

August 22, 2019 at 3:53 pm #4440961

davidF-64

My issue is resolved now. Thank you!