This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 8 replies, has 2 voices.

Last updated by Bigul 2 months ago.

Assigned support staff: Bigul.

Author Posts
July 25, 2019 at 3:20 am

tomokazuM

Hello,

We are using WPML with ACF Pro and S3 Media Offload.
We are currently running the website in english and in Japanese.
When we are creating a new updates (post type) in English, the media is uploaded to our S3 bucket and that's what we want. When we want to make the translation by duplicating the post , the image is copied to our local EC2 instance and that's not something we want to have.

We saw some troubleshooting before between WPML and S3 offload and we tried the solutions that are in those posts. Can you tell me how I can resolved this? Did we do something wrong?

Thank you!

July 25, 2019 at 9:45 am #4281529

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Welcome to the WPML support forum. I will do my best to help you to resolve these issues. Please let me know the following details for tacking the issue.

1) Does it happens with all the Posts and Pages?

2) If possible, enable the following options of WPML>>Settings>>Media Translation>>How to handle media for new content and check is there any difference in the result while translating a new post or page.


a) Duplicate media attachments for translations

b) Duplicate featured images for translations

--
Thanks!

Bigul

July 25, 2019 at 10:39 am #4281799

tomokazuM

Hello Bigul,

I just tried it on a new page with a new picture.
I upload it on the english and change the options like you said.

I try All the possible combination with ACF Pro too and it doesn't change the behavior, the file is still being copied to my local environment.

The thing is, when the content is inside the editor, the content do not move and it's okay for that but all my ACF fields are changing to a local file.

So yes it's happens to all posts / pages and I tried to enable both checkbox but still having the issue.

Thank you!

July 25, 2019 at 3:58 pm #4284961

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I can see the wrong location for the newly translated/duplicated images.

Please try the following steps and check you are getting the expected result or not.

1) Please choose copy as translation prefrence for the *hero_image_hero_mobile_image* and *hero_image_hero_desktop_image* ACF fields
2) Then create test Project post
3) Choose the following options of *Media attachments* section of language widget before publishing the Post

a) Duplicate uploaded media to translations
b) Duplicate featured image to translations

4) Publish the test post and translate it to Japanese.

Please check the attached images for more details and let me know your feedback.

--
Thanks!

Bigul

July 26, 2019 at 2:00 am #4286449

tomokazuM

Hey Bagul,

I tried your solution and it's still not working :(.
You can see all the attachment from step to step.

I added the ACF settings in attachment.

S3.jpg is how the url should look like in English and in Japanese.
EC2.jpg is actually what the translation gave us. EC2 means that it's copied to our local server and we don't want that.

Before publish is the moment I'm hitting the publish button for the english version.
Duplicate.png is when I will make the Japanese version (with the same ACF settings).

I also tried to no using the duplicate but just translate in the language panel and I have the same issue beforepublishnoduplicate.png and nodupli.jpg

Thank you for your time and effort!
Hope we will find a solution because I'm sure I'm not the only one :).

Thank you!

July 26, 2019 at 1:38 pm #4289967

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

Thank you for the updates. I have shared the details with our team for the expert opinion and waiting for the feedback now. We will get back to you soon. Please wait.

--
Thanks!

Bigul

July 29, 2019 at 3:02 am #4296641

tomokazuM

Hi Bigul,

Thank you for your message, hope to get some help today :).

T.

July 30, 2019 at 1:15 pm #4307927

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind updates, the bug reported to our developers now and waiting for their feedback. It is related to the following ticket.

https://wpml.org/forums/topic/offload-s3-integration-not-working/page/3/#post-2576661

We will get back to you as early as possible. Please wait.

--
Thanks!

Bigul

August 20, 2019 at 6:05 am #4420661

Bigul
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello,

For your kind information, our developers are still working on the fix. So as a workaround, for the time being, please add the following code in functions.php of your theme after a full site backup. Then check the issue is existing or not.

add_action( 'add_attachment', 'wpml_sync_media_custom_fields' );
add_action( 'edit_attachment', 'wpml_sync_media_custom_fields' );
function wpml_sync_media_custom_fields( $post_id ) {
    do_action( 'wpml_sync_all_custom_fields', $post_id );
}

--
Thanks!

Bigul