This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 11 replies, has 2 voices.

Last updated by timB-23 1 month, 2 weeks ago.

Assigned support staff: Paola Mendiburu.

Author Posts
April 1, 2020 at 9:58 pm #5817313

timB-23

Tell us what you are trying to do?
I am trying to reach the translations on hidden link of the same page.
Is there any documentation that you are following?
I tried to refresh the permalinks sessions, but this did not solve the issue.
Is there a similar example that we can see?

What is the link to your site?
hidden link

April 1, 2020 at 10:17 pm #5817431

timB-23

Can you also please tell me why the WMPL on the site are not updated automatically? Looking forward to your reply. Regards.

April 2, 2020 at 11:20 am #5821565

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Welcome to WPML support!

I will do my best to help you solve the problem.

In order to update the plugins, have you registered WPML in your site?

Regarding the problem with the language switcher in hidden link,
are your translations finished? If yes, Please could you try the following steps (remember to do a backup first):
- Go to WPML → Support → click on the “troubleshooting” link and in the Clean Up section click on the following buttons:
-- Clear the cache in WPML
-- Remove ghost entries from the translation tables
-- Fix element_type collation
-- Set language information

Please let me know if this fix your issue.

Kind regards,

Paola

April 2, 2020 at 9:08 pm #5826859

timB-23

Hi, thank you very much for your suggestions.

I have followed all of them (including registering the site) but unfortunately the problem persists.

Could you please give me further guidance how to solve the problem:
Regarding non functioning language switcher in hidden link.

Looking forward to your reply.

Kind regards.

April 3, 2020 at 8:52 am #5829937

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

Thanks for your collaboration.

In order to debug the problem, can you give me access to your site please?

I have just checked the necessary boxes so you can add the credentials in a secure and private way.

That way only the two of us can observe them.

I suggest you create a temporary user, so you can delete it after closing the ticket.

Kind regards,

Paola

April 6, 2020 at 8:13 am #5845283

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hello,

I have been looking into your site.

I have found that there is a redirection from hidden link to hidden link . That's the reason why it is not working the language switcher for that page.

It will work if you add the tours page as a custom link for each menu in their respective language.
For the English menu: hidden link
For Spanish: hidden link
Finally for the German menu: hidden link

Please let me know if you have any problem.

Kind regards,

Paola

April 6, 2020 at 10:55 pm #5852257

timB-23

Hi, thanks for your recommendation. I have looked into it (and had the notion that it was what you indicated, but thanks for specifying it). However unfortunately after looking around on the threads online I couldn't solve the problem. I used "sticky links" and tried hidden link . I'd greatly appreciate a step by step solution to the problem. Looking forward to your reply.

April 7, 2020 at 8:06 am #5854613

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

In order to add a Custom link please go to Appearance --> Menu, select the menu (english menu), add Custom link and fill the information, save the menu

In order to translate a Custom Link please follow this documentation: https://wpml.org/documentation/getting-started-guide/translating-menus/#translate-custom-links

Please let me know if you have any doubt.

Kind regards,

Paola

April 8, 2020 at 10:55 pm #5870113

timB-23

Hi, thanks for your instructions. However the explanation caused a bit of confusion. The expected result is that on the site with the language selector on the tour page one can reach the identified languages in WPML. The language selector( by using the flags ) works on the whole site but (minos) the tour page that you kindly visited. After reading your recommendation I already expected the solution (see image), which doesn't take away may initial request:
-Assistance with a "404 not found " using the language selector on the tour-page. How can this issue be "solved" without adding an extra custom link but by a working language selector on the tour page.
-Solved means that if one is on the tour page one can use the language selector to be referred to the other site without encountering a "404 not found" message.
Looking forward to a solution for this issue.
Kind regards.

April 9, 2020 at 8:17 am #5873161

Paola Mendiburu
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Madrid (GMT+02:00)

Hi,

I have been working on your site and the problem was with the permalinks.

If you go to Settings--> Permalinks and change your permalinks to post name it works.

You can see here more information about permalinks and WPML: https://wpml.org/home/minimum-requirements/

Kind regards,

Paola

April 9, 2020 at 5:16 pm #5878417

timB-23

Hi, I've just checked it and it works. Thanks a lot for your time, guidance and solution for this problem.
Kind regards.
Tim

April 9, 2020 at 5:18 pm #5878421

timB-23

My issue is resolved now. Thank you!