This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Riffaz 3 months, 2 weeks ago.

Assigned support staff: Riffaz.

Author Posts
June 19, 2019 at 11:24 pm #4055319

andrewK-15

I'm trying to use ATE but can't access it - getting "Api error missing resource: Website not found validate site identifier" when trying to sync ATE users and translation.

I've disabled and enabled ATE for different users but none can use the editor

Link to a page where the issue can be seen: Local testing environment experiencing this issue so not possible. The live site is using a different account (client account) but is also experiencing the issue. I'm using this account because the email on the other account goes to the client not me (the developer).

This is the same issue as:

https://wpml.org/forums/topic/ate-api-error-missing-resource-website-not-found-validate-site-identifier/#post-4055255

and

https://wpml.org/forums/topic/error-api-error-missing-resource-website-not-found-please-validate-site-id/

Both of the tickets above don't tell us how to fix it, instead resolve the issue for each individual with no exposure of the solution. Please tell the broader community how to resolve the issue so we can deal with it ourselves 🙂

June 20, 2019 at 4:31 am #4056519

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for contacting WPML support.

We are not giving the exact way of solving this here because this has to be changed in our server.
When you register the ATE first time the URL of your site will be saved in our server and there is no any option to change it from your site or from our supporters site.
This can be updated only by it's relevant department. 🙂

So,
1. when did you register the ATE ?
2. What was your site URL or domain when you registered it?
3. What is your site URL now?
4. What is the value when you run this query?

SELECT * FROM wp_options WHERE option_name LIKE '%WPML_SITE_ID%'

5. go to WPML > Settings > how to translate posts and pages

below the ATE settings there will be a link that will send you to a WPML site where you can check the translators permission. in that page there will be a menu on top of the page.

click on website and then go to "site identifier"

check that value and let me know.

Regards,
Riffaz.

June 21, 2019 at 12:58 am #4063701

andrewK-15

Thanks for Clarifying Riffaz.

1. Around November 2018 - can't confirm this exactly.

2. The original would have been dufs.test or dufs.lynxdigital.com.au

3. The live site is downunderfarmstays.com.au but I'm using dufs.test as a local development environment.

4.
- From my local dev environment:

992873	WPML_SITE_ID:ate	32303063-6463-5439-b864-313536383064	no
992888	WPML_SITE_ID:global	63396632-3137-5061-a539-646635363336	no

- From the live environment:

992873	WPML_SITE_ID:ate	32303063-6463-5439-b864-313536383064	no
992888	WPML_SITE_ID:global	63396632-3137-5061-a539-646635363336	no

5. This is the site identifier found when accessing the websites area from ALL of the urls I've mentioned:

<em><u>hidden link</u></em>	63396632-3137-5061-a539-646635363336

Urls:
dufs.test
hidden link
hidden link

I this is obviously the issue. I need dufs.test and dufs.lynxdigital.com.au to be associated with one account and downunderfarmstays.com.au to be associated with a different account.

This url is most like left over from the original migration we did from our staging site dufs.lynxdigital.com.au.

We regularly migrate a copy of the live site to our local environments to test new features ect so how can we make sure this down't happen again in the future?

June 28, 2019 at 12:29 am #4103267

andrewK-15

Still having this issue - any movement on your end?

June 30, 2019 at 6:15 am #4113435

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

I notified this to the relevant department.
This will be fixed by Monday evening.

Apologies for the delay.

Regards,

July 1, 2019 at 11:39 am #4118535

Riffaz
Supporter

Languages: English (English )

Timezone: Asia/Colombo (GMT+05:30)

Hi,

Thank you for your patient.

Just update

WPML_SITE_ID:ate

with the value of

WPML_SITE_ID:global

(63396632-3137-5061-a539-646635363336 in your case)

hopefully, this will help you to understand how to fix this.

Let me know if you need anything else regarding this.

Regards,
Riffaz.