This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I'm using ATE service and after translated a page (100% completed and delivered with positive message) it remains with spin icons and it's not in the list of translated pages

Solution: Once you finished the translation of the page using the ATE then you have to visit WPML -> Translations and that's is, the icon will automatically update.

Relevant Documentation:

This topic contains 14 replies, has 2 voices.

Last updated by Carlos Rojas 5 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 20, 2019 at 8:44 am

danieleZ-3

I'm using ATE service and after translated a page (100% completed and delivered with positive message) it remains with spin icons and it's not in the list of translated pages

May 20, 2019 at 9:32 am #3845603

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.

I would like to ask you to follow this steps in order to isolate the cause of the issue:
- Back up your site first before making any change, this is for security reasons.
- Update all outdated plugins, themes and core.
- Flush any cache memory that might exists.
- Deactivate all the plugins that are not related to WPML and Elementor.
- Switch for a moment to a WordPress default theme like Twenty Seventeen.
- Try to reproduce the issue.
- If the issue is gone, activate one by one to see with which one there is an interaction issue.

Could you tell me the result of this steps?

Kind regards,
Carlos

May 20, 2019 at 10:50 am #3846079

danieleZ-3

Hi Carlos

i created a test ambient and the situation is this:
on live website (not updated) spin icon remain and translated page number does not change
on test website (update and with Twenty Nineteen and also WPML and Elementor) spin icon still remain, BUT if i switch language, translated page nummber is +1 and then if i return to english language, i see pencil icon and no more spin icon. This "trick" does not works on live website

May 20, 2019 at 12:51 pm #3846991

danieleZ-3

On the test website, spin icon was just for few seconds. So i tried to enable theme and all plugins and the situation was the same (all ok). So i updated live website, but the problem is still there

May 20, 2019 at 2:32 pm #3848003

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you very much for your feedback.

Please go to WPML -> Translations and then double check if the issue persists?

Regards,
Carlos

May 20, 2019 at 2:48 pm #3848109

danieleZ-3

Hi Carlos

i think i miss what i have to check... in that page i see only 8 lines, and in those lines there isn't the page i'm using to test the problem. Do i have to do someting?

May 21, 2019 at 8:11 am #3852973

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

You only need to go to WPML -> Translations, there you will find the page 'After Certification' and the icon should change to a pencil once you return to the Pages list. I just followed the same steps and now you can see that the translation to Italian is finished.

Note: This issue appears to be a minor JS conflict.

Regards,
Carlos

May 21, 2019 at 8:30 am #3853205

danieleZ-3

Hi Carlos

problem is still here: there are other pages (such as "Antarctic Krill") with the problem. I can't see it in WPML->translations and spin remain (with page seen as not completed in the list)

May 21, 2019 at 9:11 am #3853437

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
Thank you for your feedback.

I just followed the steps again with the Antartic Krill page and you can see that the issue is solved. Once you finished the translation of the page using the ATE then you have to visit WPML -> Translations and that's is, the icon will automatically update.

As I said before, this issue seems to be caused by a minor conflict at JS level.

Regards,
Carlos

May 21, 2019 at 9:33 am #3853607

danieleZ-3

Hi Carlos, i tried again but after completed ATE, when i go to WPML-> Translations, i do not see the page with problem (in this third case is "Freshwater Fish" ). And so when i return to pages it is with spin icon. What i'm doing wrong?? how can i show you what i do? do i have to record a video or you have something like teamviewer ?

May 21, 2019 at 11:34 am #3854837

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

The fastest way for me to see the steps you are following is if you record a video and share a download link.

Regards,
Carlos

May 21, 2019 at 12:43 pm #3855289

danieleZ-3

Hi carlos here the video : hidden link

May 21, 2019 at 6:42 pm #3858325

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for the video.

It seems that in this case the issue was caused by some kind of cache memory. I followed this steps and the issue was solved for that page:
- Edited the 'Freshwater...' page in the original language -> Made a small change -> Saved the page -> Updated the translation (this steps refreshed the entry of the page in the database) -> Went to WPML -> Translations and now you can see that the pencil icon is shown and that the page appears in WPML -> Translations.

As I mentioned in my previous message, this seems to be a minor conflict in JS or in a cache memory.

Regards,
Carlos

May 21, 2019 at 7:11 pm #3858455

danieleZ-3

My issue is resolved now. Thank you!

May 22, 2019 at 8:29 am #3863051

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos