Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Tagged: 

This topic contains 16 replies, has 3 voices.

Last updated by Otto 4 years ago.

Assigned support staff: Otto.

Author Posts
June 16, 2016 at 2:38 pm #915766

Kristof

I am trying to: Attache a NextGen gallery to a post

URL of (my) website where problem appears: hidden link

I expected to see: NextGEN menu inside popup

Instead, I got: popup with Fatal error: Class 'WP_Installer_API' not found in /home/casaboavista/public_html/wp-content/plugins/wpml-translation-management/inc/translation-proxy/translationproxy.class.php on line 601

Steps to duplicate the issue: Create a new page, try to attach a NextGEN gallery to a post.

I have seen previous posts were people report a blank popup screen, this not entirely corresponds to my problem, where the popup is loaded but displays a Fatal error.

June 16, 2016 at 8:30 pm #916237

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you for contacting the WPML support!

I replicated the steps you provided in a fresh install and in my case, NextGen Gallery is working fine with WPML 3.4. I managed to add a gallery to a post without problems.

So, we need to check if there is a code conflict:
-Back up your site first
-Deactivate all the plugins that are not related to WPML, keep also NextGen Gallery
-Switch for a moment to a WordPress default theme like Twenty Fourteen.
-If the issue is gone, activate one by one to see with which one there is an interaction issue

Also, try reinstalling WPML and it's add-ons with a fresh copy to make sure it is properly installed.

Let me know your results, please.

Kind Regards,

Otto

June 17, 2016 at 3:04 pm #917430

Kristof

I have just disabled the Translation Mgmt plugin, and now I am able to Attach a NextGEN gallery to a page/post.

June 17, 2016 at 5:17 pm #917715

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you.

And did you try the steps that I mentioned before? It is possible that some other piece of code is interfering there.

I do understand that this test can be annoying or even impossible to perform on a live site.

So, to further debug the problem I'd like to replicate your site locally. For this, I'll need to temporarily install a plugin called "Duplicator" on your site. This will allow me to create a copy of your site and your content. If you prefer to do it on your own, you can provide me with the snapshot following these directions:

If you already know how Duplicator works (http://wordpress.org/plugins/duplicator/), please skip the following steps and just send me the installer file and the zipped package you downloaded.

Please refer screenshot attached, remember to enable the filters and exclude this:
+ wp-uploads
+ cache
+ media
+ archive

Excluding these things will help in keeping the snapshot size minimum

:: Duplicator instructions
hidden link

. Send me both files (you probably want to use DropBox, Google Drive, or similar services, as the snapshot file will be quite big)

Once the problem is resolved I will delete the local site.

I am enabling private message for your next reply so that you can send me snapshot link and admin details of the account you will create for me.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Thank you for your cooperation for debugging this issue.

Kind Regards,

Otto

June 21, 2016 at 3:13 pm #922894

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you very much.

I cloned your site locally and managed to reproduce the issue. I'll take a deeper look and get back to you soon.

Kind Regards,

Otto

June 21, 2016 at 8:33 pm #923460

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello again,

We are still investigating the issue, I consulted to our second tier support. I'll be back to you as soon as I have news regarding this issue.

Thanks for your patience.

Kind Regards,

Otto

June 22, 2016 at 11:33 am #924245

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Please try the following:
Go to WPML > Support > Troubleshooting, under the section of “Reset professional translation state” you will find a button called “Enable other translations services” and click it.

Here you have more documentation about this:
https://wpml.org/documentation/content-translation/preferred-translation-service/

Also, can you please update WPML and it´s add-ons to their latest versions? Please back up your site before updating.

Let me know if this solves the issue, please.

Kind Regards,

Otto

June 22, 2016 at 12:21 pm #924293

Kristof

Hi, we are already on the latest version of the plugin and add-ons.
We don't see the Enable other translations services on the troubleshooting page.

Troubleshooting ‹ Casaboavista — WordPress.jpeg
June 22, 2016 at 12:43 pm #924412

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

This is weird, because I do see it on my local copy of your site 🙁

Is it possible for you to grant me access to your site? Please backup your site before

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

** IMPORTANT **

- Please make a backup of site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:

hidden link

Kind Regards,

Otto

June 22, 2016 at 7:11 pm #925342

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you, I managed to log in and to add other translation services. But the issue persists.

Can you please update the NextGen Gallery plugin and reinstall WPML manually.

To do it follow this steps:

==>Backup your website and database<==
-Deactivate all WPML plugins.
-Login via FTP to your wp-content/plugins/ folder.
-Delete all WPML folders.
-Go to http://wpml.org/my-account/downloads/ and download the latest WPML Multilingual CMS Plugin, then extract it.
-Upload the plugin via FTP to wp-content/plugins/ folder.
(alternatively you could upload the .zip folder using Dashboard > Plugins > new > upload)
-Activate the WPML plugin via WP Dashboard > plugins
-Complete the setup, if needed
-Register WPML for your site (at the end of setup, clic on “generate key” button)
-Navigate to Dashboard > Plugins and locate WPML Multilingual CMS
-Click on the blue link that says “Registered”
-Download and activate all needed WPML AdOn Plugins

This should not generate any problems.

Let me know your results, please.

Kind Regards,

Otto

June 23, 2016 at 8:53 am #926034

Kristof

I have not updated NextGEN as it was already on the latest version. I did however deleted and reinstall the WPML plugins, but I hate to say, this still has not solved the problem.
We still see this error in the popup

Fatal error: Class 'WP_Installer_API' not found in /home/casaboavista/public_html/wp-content/plugins/wpml-translation-management/inc/translation-proxy/translationproxy.class.php on line 601

June 23, 2016 at 10:37 pm #927660

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

Thank you very much for your patience and cooperation.

I'm checking the issue with our second tier support and I will get back to you soon.

Kind Regards,

Otto

June 24, 2016 at 2:27 pm #928609

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

I escalated the ticket to our second tier support. They will investigate further and get back to you as soon as they have an answer.

Please apologize for time this is taking, but the issue is a little tricky as I managed to solved it in my local copy of your site, but the same solution didn't work on your site.

Kind Regards,

Otto

August 22, 2016 at 9:27 pm #1014887

Otto
Supporter

Timezone: America/Argentina/Buenos_Aires (GMT-03:00)

Hello,

We have released a new version of WPML that should fix this issue.

Can you please update WPML and it´s add-ons to their latest versions and let me know if the issue persists after that? Please backup your site before updating.

Let me know your results, please.

Kind Regards,

Otto

August 31, 2016 at 9:47 am #1043403

Kristof

The NextGEN gallery pop-up now loads perfectly, thank you.