This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 13 replies, has 2 voices.

Last updated by christoforosA 1 month ago.

Assigned support staff: Jamal.

Author Posts
February 24, 2020 at 2:07 pm #5555215

christoforosA

I have created several product attributes. Then I translated them
I had some errors on my translations, so I went back to Admin > Woocommerce > Woocommerce multilingual > Attributes, selected the preferred attribute and on the bottom of the page I have edit the name of the attribute.
The problem is that When I visit the front page it is not changes, it still shows the old one.
So I cleared caches on my cache plugin, I cleared caches on CloudFlare, I cleared caches on Browser but I still see the old translation.
Why this might be happening? Is there any other way to edit the translation of an attribute beside the Admin > Woocommerce > Woocommerce multilingual > Attributes

What is the link to your site?
hidden link

February 25, 2020 at 2:03 pm #5562955

christoforosA

Can someone help me on that?

February 26, 2020 at 6:07 pm #5573519

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Hello,

Thank you for contacting WPML Support. I will be glad to help with this.

Our apologies for the late reply, we have had a high load of tickets and we are doing our best to answer quickly. You may also consider using our chat.

Product attributes may be global to the website or local for the product, if the attributes are local, you will need to translate them in the translation editor while translating the product.

If the attributes of the products are global, they get translated in Woocommerce->Woocommerce multilingual->Attributes.

Can you give me more details on this issue?
What is the page where you see the issue?
What are the attributes that are not updated on the front and what should they show?

Can you also allow me temporary access to your website to check this further? If yes, please take a database backup before sharing credentials. Your next reply will be private to protect your website credentials.

Best regards,
Jamal

February 27, 2020 at 11:54 am #5577653

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

The product translation was needing an update, but even after updating it, it did not help. The attributes seem to be global and I still suspect that there is another layer of cache(Maybe Memcache, OPCache) or probably a theme issue.

Check the attached image, if we switch the theme to Twentytwenty, the issue is not present. And also if we used the parent theme WoodMart, the issue is not reproducible.

Please update the attribute again with the parent theme and check if the issue is reproducible. And it may be a viable workaround.
If it does not, maybe this is only happening with the child theme.

We may need to try to reproduce the issue on our test server with the child theme and escalate the issue to our compatibility team for further investigation.

February 28, 2020 at 10:21 am #5584291

christoforosA

Thank you for your reply.

I tried changing the theme on my working site but it did not helped.
The error is still there. Check the attached image.

But on the development site I switched back to woodmart theme and it works as it should.
I guess that this is cache related issue. But I followed the standard procedure.

Deleting cache on:
on my server (manually).
on litespeed plugin
on cloudflare
on browser

What else could need updating?

February 28, 2020 at 11:22 am #5584637
christoforosA

If I visit the Admin > Products there is an option on the header banner with a flag to switch between languages.
But if I visit the Admin > Products > Attributes there is no such option.

Why?

New threads created by Jamal and linked to this one are listed below:

https://wpml.org/forums/topic/language-switcher-on-products-attributes-admin-page/

February 28, 2020 at 1:55 pm #5585847

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

What else could need updating?

Maybe there is an additional layer of caching either on the web server or the database server. Can you give more details about your hosting? Are you using a hosting provider or are you hosting on your own server?

February 28, 2020 at 1:58 pm #5585875

christoforosA

I am hosting this on a VPS on Digital Ocean and I use Cpanel - WHM and Litespeed for server.

February 28, 2020 at 3:04 pm #5586565

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Please purge LS Cache as you can see it in the attached image and check again.?

Would it be possible to share access to the production server?

From my side, I'll ask advice from our 2nd Tier and get back to you.

February 28, 2020 at 3:47 pm #5586851

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

My apologies for the screenshot. I added it again to my last message. But that did not help with the child theme, maybe we need to switch to parent theme and check it.

Our 2nd Tier has suggested to:
- If you switch back to child theme then the issue reappears?
- If this is the case then please try to save the translation again, try enabling/disabling plugin.
- Switching theme or disabling/enabling plugins clears the cache

Please take a full backup of the live site and try:
- Switching the themes to parent, child and a default theme to force the cache clearing.
- Deactivating/reactivating plugins, especially the cache plugin.

Finally, if the issue is not resolved, we may need to run some tests on the production site. What would be the best time to do so? Please make a full backup before we can try anything.

February 28, 2020 at 5:28 pm #5587771

christoforosA

Earlier today I tried this:

Enabled parent theme then switched back to child theme. Did nothing!
Enabled twenty twenty theme and then switched back to child theme. Did nothing!
Disabled all WPML plugins and then enabled them again. Did nothing!
Deactivated, then deleted the cache plugin and then installed and activated it again. Did nothing!
After each step and before checking the translation I always deleted all the caches.

There is no best time in order to do this, because I get clients and orders from everywhere.
We just need to agree that you will be working in a specific time frame.

February 28, 2020 at 5:51 pm #5587827

christoforosA

I found the problem. I do not why this was causing a problem but here it is.

I deactivated all plugins and themes.
Delete cache on cloudflare.
Installed a coming soon plugin (only because I did not want anyone to see the site broken).
Then installed the child theme and only the required plugins.
Everything was working fine.
Then I started to install plugins one by one (just to check).
So I found out that the "Loco Translate" plugins was causing a problem.
I do not remember translating the attributes from "Loco translate". I really do not know if there is an option for that.
Anyways it is solved.

February 29, 2020 at 8:08 am #5590547

Jamal
Supporter

Languages: English (English ) French (Français )

Timezone: Africa/Casablanca (GMT+01:00)

Great 🙂 I am glad you could resolve the issue!

I'll have to kindly ask you to mark this ticket as resolved and open a new ticket for any other issue.

Best regards,
Jamal

March 3, 2020 at 9:24 am #5606157

christoforosA

My issue is resolved now. Thank you!