Please make sure to update to WPML 4.3.6 and check our list of Known Issues before reporting

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by georgeI-4 6 months, 2 weeks ago.

Assigned support staff: Yvette.

Author Posts
August 6, 2019 at 11:51 am #4347009


I am trying to: translate greek product attributes in the English language and they do not appear properly. Also, string translations seem to not work.

On the backend, everything seems right.

Link to a page where the issue can be seen: hidden link

I expected to see: English in Additional information

Instead, I got: the greek attributes version.

Also here: hidden link the From text is not working as it should in greek version.

August 6, 2019 at 1:30 pm #4347791


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)


1. Diagnostic
As a diagnostic step only, are the attributes translating as expected if you temporarily change your active theme to Storefront?

What if you ALSO temporarily deactivate all non-WPML plugins....are the attributes translating in these conditions?

2. WCML Configuration Errors
Please go to the panel: Woocommerce > Woocommerce Multilingual > Status
Are there any errors / notifications that you can correct?

3. Clarification
3.1 Is this happening with all products? or just this particular product?
3.2 Can you cofirm that you have translated all the attributes? and that the product itself is COMPLETELY translated? by this I mean that when you look at the product in the products listing overview, there is a pencil icon in the languages column...and not a gears icon that indicates a translation is in progress.

Thanks for your feedback on this.

August 6, 2019 at 3:56 pm #4349265


Hey there Yvette,

1. I have tried what you proposed via switching to Twenty Nineteen theme. It still does not display attributes in the proper language.

2. No, I do not think so. There is only one category that is missing a translation (it is the "uncategorized" one. Please check screenshot 2.jpg.

3.1 Yes, it is happening with all the products in the store.
3.2 Yes, all attributes are translated and all products as well. No gears icon 😀

August 6, 2019 at 5:30 pm #4349761


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

Temporary Access to your system
Please provide access to your system (wp-admin and ftp) so that I can further investigate this particular problem. The fields to provide this data are included in a private section that I will open for your next response. You can find it above the comments area. The information in this private section is only visible between WPML Support and you.

August 7, 2019 at 10:15 am #4353463


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)


Ok - I see what you are trying to do. Normally, this is a standard feature of Woocommerce + WCML using the latest versions of our product and no other non-WPML plugins.

Please see this sandbox site where it is working "out of the box" with the Storefront theme :
EN: hidden link
ES: hidden link

Here is the login info for you to see the configuraron yourself:
hidden link

This suggests that the issues would have to be with your theme or with one of the plugins that you are using. Are you sure that you fully executed the diagnostic steps of temporarily changing your active theme --AND-- deactivating all non-WPML plugins?

What you can do to rule out the possibiliyt of a theme issue is to upload your theme to the sandbox site and confirm if the attributes translate.

I wait for your feedback.

August 8, 2019 at 8:46 am #4361161


Hey there again,

The issue still persists and you seem to focus on woocommerce and not the String Translation which is not working as well.

That is why I think that there must be a wpml issue, not a theme or plugin one.

Yes, I am sure that it did not work by changing the template and deactivating all the plugins.

Thanks again for your time and help. 🙂

August 8, 2019 at 9:24 am #4361467


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)


1. Issues
You wrote: "... you seem to focus on woocommerce and not the String Translation which is not working as well..."

Technically, we should only be handling one topic per forum thread - so I started with the "larger" one which could be a compatibilty issue with something in your installation.

For the other ST issue, we can/will look at this in a new ticket or after we have resolved the first one.

2. Compatibility
Alright - could you then please then upload your theme to the sandbox site so that we can definitively rule out the problem of theme compatibility?

There is a reason for the "method" of using a sandbox site. Once you load up the theme there, I can also look at the String Tranlsation issue.

If, on the sandbox site, the strings are translating as expected....then there is a different kind of problem amiss perhaps related to your server settings.

I appreciate your patience in following this method of troubleshooting....there really is a reason to doing it this way which often results in a faster resolution.

I wait for your news that this has been done.

August 9, 2019 at 7:44 am #4368261


Hey there,

Of course and I will follow your method. You know better at these issues so no problem at all.

I just uploaded the template and also added the plugins the theme wants to operate.

Feel free to look around.

Thank you again for your time and feedback!

August 9, 2019 at 9:29 am #4368999


Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+01:00)

thanks again for collaborating on the sandbox site.

I regnerated the Strng Tranlsation cache tables and this seems to have done the necessary for the site to translation the Additional Information content and the "From" string.

This was done here:

WPML > Support > Troubleshooting > Cleanup > Recreate ST DB cache tables

Please confirm this on your side.

August 12, 2019 at 7:53 am #4378983


My issue is resolved now. Thank you!