This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Author Posts
May 6, 2019 at 9:08 am #3746115

open-sky-pressL

sir i'm trying to add attributes till week but thay are locked in other languages and if they edited in english language and then save it cannot work and these are not show in other languages.

May 6, 2019 at 9:15 am #3746207

open-sky-pressL

sir i want to add attributes and save them in other languages but this cannot be done and they are also locked in other languages

May 6, 2019 at 9:59 am #3746733

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

The screen you have uploaded is the screen for related products (not attributes). In any case, these kinds of pricing-related information is locked in all 2nd languages and should be set only in the primary default language.

Once they are set and saved in the primary language, the values shoudl be syncrhonised to the translated version provided that the attributes/related-products are also existing in the target language.

May 6, 2019 at 5:20 pm #3751389

open-sky-pressL

all these items are locked and attributes are not saved after editing in english

May 6, 2019 at 6:05 pm #3751795

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

The screenshot you are showing me indicates that the language version you are attempting to edit is German (DE).

As I mentioned before, product information that is sensitive to pricing, inventory or even product identification will be locked in languages that are NOT the primary language. In your system info, I see that your default language is English.

This means that you can only edit data in English and have them copied/synchronised to your other languages.

If you are attempting to translate the LABELS of these attributes, then you should do this using the
WPML > Taxonomy Tranlsation tool for "Global attributes".

For "Custom" attributes, then you should mark the custom fields as "Translate" here.
WPML > Settings > Custom Field Tranlsation
and then use the translation editor (CTE or ATE) to change the Labels.

I hope this answers your question. If you need more support, please provide a concrete sample product and attribute along with system access details and I can see if I can upload a screencast or screenshots demonstrating how you would translate the attributes.

May 7, 2019 at 11:58 am #3757497

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hello

Yes, you are using custom attributes but the associated custom field was set to "Do not translate"

I have corrected this (see image) and now, you should see these attributes appear in the Translation Editor. You might have to "resave" the English version to get them to load into the editor first, however. You can do this one-by-one as you go....or you can try doing a bulk-edit.

This mean selecting all of your products on a single page, then going to "Bulk Edit" and then doing an "update" without making any changes. Do this for each page of your products. The action of resaving the post in the original language will trigger the copy of the custom fields to other languages.

May 7, 2019 at 7:01 pm #3761417

open-sky-pressL

Mam you can see in image i have change price (pic 2) for bulk quantity of products but still not changed.

May 8, 2019 at 9:20 am #3764939

Yvette
Supporter

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

1. Product Attributes
Is the original problem resolved now?

2. Price change & Bulk Edit
Your screenshot is showing that you are attempting to use bulk-edit to change a price in the non-default language.

Please remember - you can only change product data in the DEFAULT language. To change the target 2nd langauge, you must use Translation Editor. The bulk edit will not work.

May 8, 2019 at 2:39 pm #3767847

open-sky-pressL

My issue is resolved now. Thank you! Yvette, she is very cooperative thank you so much Yvette