This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Itamar 1 month, 2 weeks ago.

Assigned support staff: Itamar.

Author Posts
August 26, 2019 at 3:12 pm

kathleenV

I am trying to: translate the attributes in the product detail to english

Link to a page where the issue can be seen:hidden link

I expected to see: Additional information- attributes shown in english

Instead, I got: Additional information - attributes is shown in dutch

August 26, 2019 at 6:45 pm #4460857

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

I can see the issue on your site. Can you please confirm that it is what I show on the attached screenshot?

Also, please confirm that you are following our instruction on how to translate products attributes. You can see the instructions here.
https://wpml.org/documentation/related-projects/woocommerce-multilingual/#taxonomies
Please note that there is a difference between the way that you translate global attributes and custom attributes. It is explained in the documentation.

Please let me know if this information is helpful to you.

Regards,
Itamar.

August 27, 2019 at 6:54 am #4463117

kathleenV

Hello

There are no custom attributes. Every attribute is translated in english in the woocommerce multilingual section, but it dus not show on the product detail in english. The other languages are okay. The issue you show on the attached screenshot is the issue i'm struggle with.

Kind regards

Kathleen Verhelle

August 27, 2019 at 2:28 pm #4467677

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi.

Please confirm that this is not a cache issue. Sometimes cache can be as a WordPress plugin, or it can even be on a server-side or CDN. So if you are using a cache method, please clear all the cache from your site.

If it is not a cache issue, then please proceed with the following.
I suspect that there is a collision with the theme or another plugin that might cause this problem. If possible, get your site into a minimum environment. Minimum environment means switching to a default WordPress theme like TwentyNineteen and no plugins activated except WPML. You will need first to check if the problem persists when just the theme is switched to TwentyNineteen (for example). If it persists then deactivate all plugins except the WPML and its add-ons and WooCommerce itself (without any of its add-ons). Then please check if the problem persists. If it does not persist, so start by activating the plugins one by one and check when the problem comes back, then report to me which was the culprit plugin.

**** Important! Please make a full site backup (files and DB) before you proceed with those steps****


*** If your site is a live site you might want first to try those procedures in a staging environment or a snapshot of your site on your local server or another server. ***

Thanks,
Itamar.

August 29, 2019 at 11:38 am #4480559

kathleenV

Hi

I did set the site in a minimum environment and disabled all the plugins except WPML. The problem stays, the same.
Can you please login and take a look please?

Kind regards

Kathleen Verhelle

September 1, 2019 at 1:31 pm #4492543

Itamar
Supporter

Languages: English (English ) Hebrew (עברית )

Timezone: Asia/Jerusalem (GMT+03:00)

Hi, Kathleen.

I've checked things on your site. Currently, I have not found the cause of the issue. I can see that the problem only happens in English products.

Please try the following option in our troubleshooting section.
1. Take a backup of the DB of your site.
2. Go to WPML -> Support -> Troubleshooting (link)
3. Once on the troubleshooting screen press the following buttons and check if it helps.
Press each button at a time and wait for the process to complete.
- 'Set language information'
- 'Clear the cache in WPML'
- 'Remove ghost entries from the translation tables'
- 'Fix element_type collation'
- 'Fix terms count'
- 'Fix post type assignment for translations'

*** Please make a backup of your database before using this.***

Thanks,
Itamar.

The topic ‘[Closed] attributes not translated’ is closed to new replies.