This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 9 replies, has 2 voices.

Last updated by Andreas W. 4 months, 2 weeks ago.

Assigned support staff: Andreas W..

Author Posts
June 3, 2019 at 4:52 pm #3944601

alexanderS-98

Hello

in a site with 2 languages (Greek default - English) I am trying to translate the attributes slug into English. When I navigate to Woocommerce Multilingual->Store URLs I get to see that the Greek attribute slugs have the english flag.
- How can I change the language to greek in order to translate to english?
- Searching any slug in String Translation results in zero results.

Thank you for your time.

Regards,
Alexander

June 3, 2019 at 9:04 pm #3946189

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for contacting the WPML Support Forum.

The settings for WooCommerce prudct attributes can be changed at Settings -> Permalinks.

Afterwards go to WooCommerce -> WooCommerce Multilingual -> StoreURLs and translate the slugs here.

Let me know if you need further assistance.

Kind regards
Andreas

June 4, 2019 at 10:13 am #3950207

alexanderS-98

Hello Andreas

the pointed fields in permalinks are already filled.
My problem is that the attributes as displayed in the screenshot provided in my first comment, should have the greek flag (default language) and not the english one. Is there a way to change this?

Thank you for your time.

Regards

June 4, 2019 at 4:52 pm #3953849

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

I would like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. It would be better to a testing site where the issue is replicated.

You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Maybe I'll need to replicate your site locally. For this, I’ll need to temporarily install a plugin called “Duplicator” on your site. This will allow me to create a copy of your site and your content. Once the problem is resolved I will delete the local site. Let me know if this is ok with you.

IMPORTANT

Please make a backup of site files and database before providing us access.
If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box. The private box looks like this:
hidden link

Kind regards
Andreas

June 5, 2019 at 5:49 am #3957137

alexanderS-98

Hello Andreas

I do not see the fields you are mentioning. Only a yellow box to choose if the reply will be marked as private or not.

Thank you for your time.

Regards

June 5, 2019 at 3:29 pm #3962393

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Thank you for your message.

I am sorry about the inconvenience. I have enabled the fields again.

Kind regards
Andreas

June 5, 2019 at 3:49 pm #3962521

alexanderS-98

Hello Andreas

unforetunately I can not see the fields shown in your screenshot.
I send you screenshot of what I see.

Regards

June 5, 2019 at 10:39 pm #3964363

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

Could you try to access the forum with another browser and let me know it the issue persists? I will additionally add a filed in order to provide a download link to a duplicator package.
https://wordpress.org/plugins/duplicator/

If the private mode still fails please send me the info to andreas.w@onthegosystems.com

Kind regards
Andreas

June 6, 2019 at 5:39 am #3965921

alexanderS-98

Hello Andreas

I have sent you an email, titled as the topic of this post.

Regards

June 6, 2019 at 4:11 pm #3970927

Andreas W.
Supporter

Languages: English (English ) Spanish (Español ) German (Deutsch )

Timezone: America/Lima (GMT-05:00)

Hello,

There is some odd issue on your site.

I realized that slugs do show up at WooCommece Mutlilingual (WCML) various times in Greek and English as default language while they been assigned to wrong language.

I then checked the WP Endpoints domain on String Translation and realized here onlz slugs in default English language. Afterwards I scanned WooCommmerce and WCML for new strings at WPML -> Theme and Plugin localization.

When then trying to access String Translation again the backend of your site was not working (Error: file not found) and further the FTP access was denied.

Could you please try to run the site in minimal setup to see if the issue persists?

Please disable any additional plugin that is not related to WPML and its add-ons. If the issue disappears please start reactivating any plugins, or activate them in small groups. This way please verify at which points the issue appears again to indicate the plugin that is causing the issue.

Also please change to a default theme like TwentySeventeen to see if the issue might be theme related.

Further, you could enable the wp-debug feature to see if there are any current PHP errors given.

Add the following to your wp-config.php file:

define('WP_DEBUG', true);
define( 'WP_DEBUG_LOG', true);
define( 'WP_DEBUG_DISPLAY', false);

The wp-config.php is located in your WordPress root directory. It’s the same file where the database configuration settings are. You will have to access it by FTP or SFTP in order to edit it.

If you open wp-config.php and that define statement is not there, you can add it right before this line:

/* That's all, stop editing! Happy blogging. */

You will be able to see errors on front end, backend and further find a complete report inside of your wp-content folder. Look for a debug.log file and provide me the results.

More information about how to activate this feature you can find here:
https://wpml.org/documentation/support/debugging-wpml/

Kind regards
Andreas

The topic ‘[Closed] Attributes slug appearing in wrong language’ is closed to new replies.