This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 18 replies, has 2 voices.

Last updated by thomasK-90 3 weeks, 2 days ago.

Assigned support staff: Raja Mohammed.

Author Posts
September 13, 2019 at 4:52 pm #4570189

thomasK-90

I have a general quetion.
Is is necessary to have product attributes translated? If I want to use the same name and slug for them, not neccessary to translate? Or is there any limitations if I don't translate them?

September 16, 2019 at 6:39 am #4576563

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Hello there,

If you wish to keep the product attributes the same in translation, Please choose the "Translatable - use translation if available or fallback to default language" option in WPML > Settings > Taxonomy translation . for the appropriate product attributes.

This will display the product attributes in the default language if the attributes are not translated. There is no such known limitation this should work fine as expected.

Let me know if you need further assistance.

Kind regards
Raja

September 18, 2019 at 10:07 am #4594835

thomasK-90

I actually have that setting. And now when I do the bulk edit, then variable products options associated with them disappears on frontend (not selectable). And on the backend, I need to re-apply the variation use for options, then associate one by one.

September 18, 2019 at 11:16 am #4595541

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Sorry, I don't understand your response. Changing the settings prevents the variation from displayable in the frontend for the translated products? Are you sure the variations is not translated already?

Secure a backup of your site and database
- Goto WooCommerce > WooCommerce Mutliglingual > Settings
- Click on troubleshooting link at the bottom of the page
- On the troubleshooting page check
[x] Update products count:
[x] Sync products variations:
[x] Sync product stock quantity and status

Wait for the process to complete. Check if your issue is resolved.

let me know the results

September 18, 2019 at 4:00 pm #4598443

thomasK-90

What I mean is, for example, when I allocate product A,B,C to Sale category with the bulk edit, then they lose the size options associated with them.
For product A, I have size S and M. They don't appear frontend. When I go backend, then these options are missing from the variables I selected to use for variation.
Could I make myself clear?

September 19, 2019 at 7:37 am #4602031

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Please provide a snapshot copy of your site let me try on my local environment, you can use the Duplicator plugin to create a snapshot of the site and share the package link with me http://wordpress.org/plugins/duplicator/

I have enabled private fields for you to securely share the details.

September 19, 2019 at 12:54 pm #4604897

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

I am checking this request. I will update you soon.

September 20, 2019 at 5:54 pm #4614017

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

The site is very slow in the local environment and it's generating a lot of php notices on every page load. Trying to figureout a way to reduce the response time. I will continue the test on Monday.

September 20, 2019 at 6:03 pm #4614033

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

\ Finally I am able to test with these two products in bulk update Nida Skirt – Silk Rib and Ware Pants – Merinos Wool, I have changed the category to New this seems to load without any issue the Attributes stays intact I don't see any disconnection checked the translation as well the Variation attribute M/L displays without any issue.

Since the site response is very slow I have tested the bulk update with just two products and it works, I'm not whether it would break if do more number of products in bulk update. In case if I am missing any stesp It would be better if you give me clear steps to reproduce the issue or a screencast might help better you can use loom.com to capture your screen and share the recored link with me.

September 21, 2019 at 2:41 pm #4616183

thomasK-90

That is already an issue. Those products should show XS/S option as well. But it is not selectable. Also it dissappears from attribute setting(as in image variations2.png. I have selected both XS/S and M/L).

September 23, 2019 at 2:02 pm #4624841

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for the information, Checking this further.

September 24, 2019 at 1:02 pm #4631781

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your patience, I think I have identified the exact reason for the issue.

Your site default language is Japanese However, there are attributes which are registered with English as default language except for the attribute "M/L" the rest of the attributes has English as the default language. When you bulk update the product form with Japanese selected in the Admin side your products are updated with those having Japanese as the default language.

It is a bit complex to explain in words, I have recorded the steps which work in my local setup Please backup your site and database before you proceed hidden link, Please run this instruction to all the attribute which has default language other than Japanese

Let me know if you need step by step instruction in writing I will try to put those in meaningful sentences.

September 24, 2019 at 5:55 pm #4633321

thomasK-90

Thank you so much for in-depth check of the issue. This was so far the best help I got on this issue.
I tried your method. Now after the bulk update, the attribute settings don't disappear. In the attached image case, the product should have XS and S options, and after the bulk update, they are still there. This is already very good.
However, then I go to the variations, they are not selected. So does this mean, I need to manually reapply each options?

September 25, 2019 at 3:41 am #4635487

Raja Mohammed
Supporter

Languages: English (English )

Timezone: Asia/Kolkata (GMT+05:30)

Thanks for your kind words.
I didn't encounter that in my trial run the variation stayed intact. However, it happened when I changed the attributes. For eg I changed XS to L but missed to update the variation in the product page before going for bulk update. This is the expected behavior. If this is similar to what you are experience then you might need to update them manually else not I might need to look into this again. Let me know the details.

September 25, 2019 at 8:14 am #4636663

thomasK-90

I didn't change the attribute. I only changed the language allocation as you suggested in the video.