This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 7 replies, has 3 voices.

Last updated by RavanH 1 year ago.

Assigned support staff: Carlos Rojas.

Author Posts
May 24, 2019 at 11:31 am #3884349


I am trying to:
Make sure that the Yoast SEO sitemap contains all translated posts, pages, custom post types, and archives.

While looking at the post, page or custom post type sitemap you can see that links for all of our 4 different languages are included correctly.
This can be seen by visiting one of the sitemaps (not author) in hidden link.

This is not the case for the author sitemap though, where only the English versions of the author archives are listed.

Link to a page where the issue can be seen:
hidden link

I expected to see:
A list of both original and translated author archive pages.

Instead, I got:
A list of only the original (English) author archive pages.

- Switch to default WP theme: Same error.
- Activate Yoast SEO Multilingual plugin: Same error.

May 24, 2019 at 11:36 am #3884359


In addition to whats already tested above, I just did the same test on a fresh WP install with only WPML and Yoast SEO plugins active and Twentysixteeen theme.

Still the same problem.

May 24, 2019 at 3:29 pm #3886051

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Thank you for contacting WPML support.

Have you set the authors to translate? You can achieve this in WPML -> String Translation -> Bottom right section.

Kind regards,

May 28, 2019 at 8:34 am #3904045


Hi Carlos,

Thanks for your support!

We've tried to enable that setting but that only makes the user meta available in String translations. No change on the sitemap sadly. Still, only the English author pages are showing up.

Kind regards,

May 28, 2019 at 10:39 am #3905759

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi David,
Thank you for your message.

If you translate the data of one of the users in String Translations, does this translations appear in the sitemaps?


May 30, 2019 at 3:28 pm #3924203



Did some tests today but without any luck.

This is what I did:
• Activate the string translation for author roles under WPML -> String Translation -> Bottom right section.
• Translated one of the authors' details.
• Checked the Author archive page and the sitemap for changes.

The English version of the author archive page is displaying in the sitemap both before and after the above changes as expected.
Translating the author strings does not add the translated version of the authors archive page to the sitemap.

I've attached screenshots of the sitemap before and after the above changes. I cut off the last names to give the users some privacy. As you can see it's the same URLs before and after and only in the original language.

One thing I noticed while testing is that even if the author has no posts in English the English author archive is still added to the sitemap. (Same probably goes for secondary languages but I have no way to validate since none of the translated author archives are added to the sitemap)

In my head the expected author sitemap functionality would be:
• Add original author archive page to the sitemap if they have posts in the original language.
• Add translated author archive page to the sitemap if they have posts in the translated language.

I'm starting to run out of ideas now, leaning more and more towards it being a bug and not a misconfiguration.

Do you have any more ideas to test?

Best regards,

May 31, 2019 at 8:38 am #3928539

Carlos Rojas

Languages: English (English ) Spanish (Español )

Timezone: Europe/Madrid (GMT+02:00)

Hi David,
Thank you very much for your feedback.

I would like to request temporary access (wp-admin and FTP) to your site to take better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.


March 12, 2020 at 2:30 pm #5673737


Hi, running into the exact same issue, this does not seem resolved. The Yoast author sitemap shows all authors that have any post (no matter which language) with the original language URL. Some authors have only posts in the translation language, which then leads to an empty "nothing found" response on their author page in the original language.

So now we have empty pages in our sitemap which is totally not good 🙁

WPLM + Yoast (with author sitemap ativated) + Yoast ML plugin...

See this author sitemap hidden link and follow the very fist author there. It will get you to hidden link which says "nothing found". The translation author page on hidden link has many posts but it does not appear in the author sitemap.

Any way to get around this except setting up 301 redirects?

Also found a related bug: see the footer language menu on that same author page. Both languages point to another author (the one with the lowest ID?)