This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 0.14 hours from now. Thank you for your understanding.

This thread is resolved. Here is a description of the problem and solution.

Problem: I created posts (in whitelab theme we call "listing") in French Version, and I try to view the content in the English version but it always redirects me to French Version. Is there a way to view the content without caring the Language? If the English version doesn't exist, take the content from French version sth like that. Is it possible?

Solution: In this case you need to go to WPML -> Settings -> Post Type Translation -> Set 'listing' post type to 'Translatable – use translation if available or fallback to the original language' -> Save the changes.

Relevant Documentation: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

This topic contains 11 replies, has 2 voices.

Last updated by Carlos Rojas 11 months, 4 weeks ago.

Assigned support staff: Carlos Rojas.

Author Posts
October 18, 2018 at 9:16 am #2827373

amaniS

I created posts (in whitelab theme we call "listing") in French Version, and I try to view the content in the English version but it always redirects me to French Version. Is there a way to view the content without caring the Language? If the English version doesn't exist, take the content from French version sth like that. Is it possible?

Already try this one : https://wpml.org/documentation/getting-started-guide/language-setup/automatic-redirect-based-on-browser-language/
but still not working

October 19, 2018 at 3:34 am #2830487

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hello,
Thank you for contacting WPML support.
I will do my best to help you solve this issue.

In this case you need to go to WPML -> Settings -> Post Type Translation -> Set 'listing' post type to 'Translatable – use translation if available or fallback to the original language' -> Save the changes.

In this page you will find our official documentation about this option: https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/

Please let me know if you need further assistance and I will be more than happy to help.
Kind regards,
Carlos

October 19, 2018 at 9:52 am #2831490

amaniS

Thank you for your helping. But I still didn't get what I expect, maybe my issue is not clear enough. Anyway, the solution above is working fine when we create a post from default language (EN) and view it in the other language (FR), but when I create a post in the other language (FR) and view it in the default language (EN), It still redirects me to Home Page. It does not take the content from the other language (FR).

**NOTE** I am so sorry, I just notice my question above has been wrong.

October 19, 2018 at 10:08 pm #2833131

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you very much for your message.

I'm sorry but I don't understand what do you mean with: "I just notice my question above has been wrong."

Could you tell me which solution you applied that is working?

Regards,
Carlos

October 20, 2018 at 5:10 am #2833833

amaniS

Hi Carlos Rojas,

I'm sorry for making you a bit confused, just forget the NOTE part. So now, what I have done is applied the solution you provide me but it is not what I want.

October 20, 2018 at 5:22 am #2833835

amaniS

Again, I create a post from the French Language and I want to view the post in the English Language without using Duplicate Content. Is it possible? Because right now, whenever I viewed the post in the English Language, the website will redirect me to the Home Page. And what I have noticed is that I don't have the post in the English Language.

NOTE
Default Language = English
Other Language = French

October 22, 2018 at 4:51 pm #2839037

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

Could you tell me if you applied this settings?
WPML -> Settings -> Post Type Translation -> Set 'listing' post type to 'Translatable – use translation if available or fallback to the original language' -> Save the changes.

Regards,
Carlos

October 23, 2018 at 9:53 pm #2844137

amaniS

Hi Carlos,

Yes, I did. But it still not working.

October 24, 2018 at 5:58 pm #2847474

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,
Thank you for your message.

Please increase the PHP Memory Limit. Minimum requirements are 128Mb: https://wpml.org/home/minimum-requirements/
You can add this to wp-config.php to increase WP memory:

/** Memory Limit */
define('WP_MEMORY_LIMIT', '128M');
define( 'WP_MAX_MEMORY_LIMIT', '128M' );

- Add it above the line /* That's all, stop editing! Happy blogging. */

Could you tell me if the issue persists after increasing the memory limit?
Regards,
Carlos

October 25, 2018 at 3:00 am #2848690

amaniS

Sorry Carlos Rojas, I already applied your solution but it's still not working.

October 25, 2018 at 10:05 am #2849387

amaniS

My issue is resolved now. Thank you!

October 25, 2018 at 3:24 pm #2850314

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,

I'm glad to hear that the issue is solved 🙂

Please don't hesitate to contact us if you need our help in the future with WPML. We will be more than happy to help.
Best regards,
Carlos