This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 5 replies, has 2 voices.

Last updated by Carlos Rojas 2 months ago.

Assigned support staff: Carlos Rojas.

Author Posts
August 22, 2019 at 12:45 pm #4439467

alastairJ

I am trying to: not register strings

Link to a page where the issue can be seen:

I expected to see: no strings registered unless I choose to register them

Instead, I got: tens of thousands of strings I don't want registered automatically

I have a handful of strings I need registered, maybe about 20. I have set "auto register strings for translation" to "Strings from all text domains are excluded".

If I visit wp-plugins.php and return to the string translation screen, tens of thousands of new strings have been registered for all sorts of text domains. On many occasions, "auto register strings for translation" has turned itself on and added text domains which I never selected.

Thousands from gravity forms, thousands from default, thousands from Yoast, thousands from WordPress and WPML, guttenberg blocks, Oxygen builder etc. I don't want ANY of these strings. I don't want or need any default admin translations in the back end of the site at all.

If I delete strings, they come back as soon as I edit anything on the site or visit the plugins screen again.

If I move a site from one server to another, every text domain is re-registered with all its strings even though "auto register strings for translation" is set to "Strings from all text domains are excluded".

August 22, 2019 at 1:04 pm #4439559

alastairJ

Also, any time I edit with Oxygen, hundreds more strings are automatically registered. This should not be happening given that "Strings from all text domains are excluded".

August 22, 2019 at 1:20 pm #4439649

alastairJ

Look at this, it did it by itself ...

August 22, 2019 at 2:43 pm #4440515

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi,

Please follow the steps I suggested in your previous message and if the issue persists I would like to ask you to close one of both tickets so we don't have it duplicated in the forum and we can continue in the on you leave open.

Regards,
Carlos

August 22, 2019 at 2:58 pm #4440663

alastairJ

The issue is not resolved. You suggested "In order to prevent the auto registration of strings you need to go to WPML -> String Translation -> And follow the steps described in this link: https://wpml.org/documentation/getting-started-guide/string-translation/#auto-register-strings-for-translation"

That link provides no information about preventing the auto registration of strings, and contains no steps to follow.

August 23, 2019 at 10:54 am #4446029

Carlos Rojas
Supporter

Languages: English (English ) Spanish (Español )

Timezone: America/Montevideo (GMT-03:00)

Hi there,
I'm sorry for the misunderstanding.

You are correct, the steps I provided where to not scan the domains and to remove already scanned strings. But not to prevent.

I consulted our specialists about your issue and there is no settings withing String Translation or WPML to prevent the strings for being registered. In this case they recommend to test the beta version which changed the way String Translation works and solves the performance associated issues.

Note: As the functionality of preventing strings for being registered is not implemented, you can create a featured request in this link: https://wpml.org/suggest-a-new-feature-for-wpml/ It will go directly to our developers team.

Best regards,
Carlos