This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

Our next available supporter will start replying to tickets in about 11.44 hours from now. Thank you for your understanding.

This topic contains 34 replies, has 2 voices.

Last updated by Mihai Apetrei 2 months ago.

Assigned support staff: Mihai Apetrei.

Author Posts
July 26, 2019 at 10:03 am #4288915

kevinD-10

I am trying to: Use machine translation for a post.

Link to a page where the issue can be seen:

I expected to see:

Instead, I got:

July 26, 2019 at 11:29 am #4289425

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi and thank you for contacting WPML Support!

I will be happy to help you with this.

Ate should recognize HTML tags and should allow you to select the string on the translation then click on the tag to apply it on it.

Can you please let me know if you encountered that situation?

If not, can you please:

1. let me know what is the link of that page/post

2. I would also like to request temporary access (wp-admin and FTP) to your site to take a better look at the issue. You will find the needed fields for this below the comment area when you log in to leave your next reply. The information you will enter is private which means only you and I can see and have access to it.

Our Debugging Procedures

I will be checking various settings in the backend to see if the issue can be resolved. Although I won't be making changes that affect the live site, it is still good practice to backup the site before providing us access. In the event that we do need to debug the site further, I will duplicate the site and work in a separate, local development environment to avoid affecting the live site.

Privacy and Security Policy

We have strict policies regarding privacy and access to your information. Please see:
https://wpml.org/purchase/support-policy/privacy-and-security-when-providing-debug-information-for-support/

**IMPORTANT**

- Please make a backup of the site files and database before providing us access.

- If you do not see the wp-admin/FTP fields this means your post & website login details will be made PUBLIC. DO NOT post your website details unless you see the required wp-admin/FTP fields. If you do not, please ask me to enable the private box.

The private box looks like this: hidden link

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 26, 2019 at 3:38 pm #4290659

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Regarding the issue with the HTML formatting, I will need to spend some time on your site and I will get back to you as soon as I have more info.

Regarding the privacy concern, I attached a screenshot with the tickets that have been created from your profile.

Can you please confirm me which is the one that you are referring to?

Please let me know.

Just a note that I won't be working on the weekend so I will be able to get back to you at the beginning of next week.

Kind regards,
Mihai

July 26, 2019 at 4:20 pm #4291041

kevinD-10

Thanks Mihai, next week is fine.
The privacy concern was about the ticket which Marcel resolved for me this morning:
'Setting up translation manager for certain posts'.
(I accidentally sent URL, UN and PW details in the thread, rather than a private area).
I can't see it among your screenshot, so perhaps Marcel deleted it?
Regards,
Kevin

July 29, 2019 at 10:14 am #4298639

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi Kevin.

I spent some time on your site and from what I can see, the content for the post is added into a custom field called "News".

My guess is that there might be an incompatibility somewhere in the middle between the current implementation and content-generation of that custom field and WPML.

Can you please try to do a translation test (for example in a new language) and instead of using ATE, can you please try to use the duplication method below and see if that works better?:
https://wpml.org/documentation/translating-your-contents/displaying-untranslated-content-on-pages-in-secondary-languages/using-content-duplication/

Please let me know how that goes.

I will be waiting for your response.

PS: Regarding that ticket with the site credentials, I can't find any with that name so it has been either deleted by my colleague, or it was a live chat and it's not public. No worries about that.

Kind regards,
Mihai

July 29, 2019 at 11:39 am #4299309

kevinD-10

Hi Mihai,

Not sure if this is correct:
I have made a new post called ‘Test post’ in (US) English.
I have clicked ‘Duplicate’ next to ‘French’
I have chosen ‘translate independently’
In this state it keeps the html formatting, but how do I translate it with ‘machine translation’?
(Please note, I have made the original (US) English post ‘draft’ to hide it).

Thanks for answering the question about the ticket with security worries.

July 29, 2019 at 4:01 pm #4301615

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

Unfortunately, by using the duplication method (not ATE), you can't use machine translation but I was curious to see if it would work that way.

My guess is that there might be somewhat of a conflict between WPML and at least one of the other plugins or custom code if there's any.

Can you also please try this:

- disable all plugins except WPML and its add-ons (also, leave the "Advanced Custom Fields PRO" plugin active)
- check if the issue is happening again (use ATE to translate a test post and see if this time it takes into consideration the spacing)
- if it's not, reactivate your plugins one by one, checking every time if the issue shows up again so that you can understand which plugin is causing that issue

If the issue happens even with the non-WPML plugins disabled:

- leave all the non-WPML plugins deactivated
- switch to a default theme like TwentySeventeen
- try to recreate the issue now

Please let me know how that went and if anything changed while following the steps.

I will be waiting for your response.

PS:
I am at the end of my shift at the moment but I will be able to get back to you tomorrow.

Kind regards,
Mihai

July 30, 2019 at 8:41 am #4305771

kevinD-10

Hi Mihai,

Unfortunately, it will not be possible for me to disable all plugins except WPML, as this is a live site. (Also, the plugins are all required for functionality of the site).

I am not sure the problem is related to one of the other plugins. It seems to be related to choosing the 'wysiwyg' type of custom field within 'Advanced Custom Fields Pro'. The ATE recognises the tag, but not the <p> tag.

The only way I can think of to overcome this problem is for my Client to add <p> tags as follows:
From the master (US) English post, click the pencil to edit the French version.
Add <p> and </p> tags as required (see screenshot).
Save and close.

Can you confirm that this will work?

(My Client might accept this, I will ask them).

If you can think of another way to fix this, please let me know.

Regards,
Kevin

July 30, 2019 at 3:55 pm #4309479

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I don't know if you did something but the paragraphs are correctly spaced now from what I can see here:
hidden link

Can you please check and see if it looks the same on your side, too?

I will also attach a screenshot.

Kind regards,
Mihai Apetrei

July 30, 2019 at 4:01 pm #4309527

kevinD-10

Yes, I added the <p> tags as I described. (However that is not an entirely satisfactory situation, a fix would be better).

July 30, 2019 at 4:09 pm #4309579

kevinD-10

Did you see the full message and screenshot from this morning? (Perhaps they didn't come through, due to my putting tags into the message).
Anyway, the way I overcame the problem was by adding the paragraph tags back in. From the master (US) English post, I clicked the pencil to edit the French version, then added the paragraph tags , saved and closed. Can you confirm that this will work without causing any other issues?
(My Client will not be particularly happy to do this, so a fix for the problem would be better.)

July 30, 2019 at 4:12 pm #4309609

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

I see.

I totally agree that a fix would be better.

I created a sandbox testing environment on the link below (one-click login):
hidden link

WPML + the WPML add-ons are already installed (you would need to configure WPML with the same languages you are using on the live site and then enable WPML String Translation and Translation Management).

After that, all I would need from you is to install the theme that you are using + the plugins needed to recreate the issue (the idea of a clean sandbox environment is to avoid as much as possible to add any other extra plugins that are not needed, so we would need just the WPML plugins and whatever is needed to recreate the issue.

If you will be able to recreate the issue on our servers, too, that's when I can forward this to our Compatibility team as I think this might be a compatibility issue after all.

Will you please let me know when that's done and what is the result so that we can move forward with this?

Thank you very much for your cooperation.

I will be waiting for your response.

Kind regards,
Mihai Apetrei

July 31, 2019 at 8:53 am #4313039

kevinD-10

Hi Mihai,
I have added the same languages and enabled WPML String Translation and Translation Management
I have installed the theme.
I have added Advanced Custom Fields and added a Field Group to match the one for Posts.
I have made a post called ‘Test Post’.
I can’t go any further, as when I click the ‘+’ sign, it doesn’t give me the option of translating using ATE.

Can you confirm that I can use the ‘workaround’ of adding paragraph tags for the time being without it causing any problems?

July 31, 2019 at 3:22 pm #4315973

Mihai Apetrei
Supporter

Languages: English (English )

Timezone: Europe/Bucharest (GMT+03:00)

Hi.

I went to your post and I clicked on the button that the arrow in my screenshot is pointing to.

Then I went to WPML > Settings and I selected "Use WPML's Advanced Translation Editor" (I'm attaching a screenshot for this, too).

Now ATE should be the default translation editor so you can try now if you want.

Regarding your second question, yes, that workaround should be fine (even if it should normally work straight away, without you needing to add the HTML tags). I can also see it working very well on the live site in the form that you added it now.

Kind regards,
Mihai

August 1, 2019 at 12:29 pm #4321629

kevinD-10

Hi Mihai,
The English post (Screenshot 1) has two paragraphs.
When I click on the 'pencil' next to the post for the French version of the post, I am not seeing the option to use ATE. (See Screenshot 2).
(What's more, The other two paragraphs don't seem to be there?).