This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 29 replies, has 2 voices.

Last updated by Alejandro 5 months, 1 week ago.

Assigned support staff: Alejandro.

Author Posts
April 4, 2019 at 6:23 am #3532191

Fabio Massimo Pari

Today must be a good one, because of the update to 4.5 of Woocommerce Multilingual.
But definitely not.
The problem I found is not fixed.

Situation:
our main language is Italian.
If I change a single letter in english and I save the product, the plugin modify also the product category, applying a new slug for the category.

The original slug:
hidden link
changes to
hidden link

I opened a ticket, but no solutions from you.
I lost time uploading a site copy to your debug system, but no solutions from you.

The right an only question is: why to pay for this kind of service? The problem exists since more than 1 month in your total silence.

April 4, 2019 at 12:43 pm #3534937

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hello!
Welcome to WPML Support.
I'll do my best to help you solve this issue.

(i see that you also speak Italian, so if you want to continue in Italian just say so).

So, as a first thing i tried to find a ticket where you mentioned the problem you're having today but i couldn't find the one (if you point it out for me, i can start from where you left off last time).

If you want, you can grant me access to your site, because this seems like you added a product category base in Settings > Permalinks but if you didn't then there's something we need to check in there.

Let me know so i can do my best and be as fast as possble to find a solution or at least a workaround for your problem.

Regards.

April 8, 2019 at 7:06 am #3554581

Fabio Massimo Pari

Grazie Alejandro.
Questo problema va avanti da 1 mese e più. Sarebbe bello risolverlo.
Comunque nessuna risposta seria da parte vostra e la direzione della mia azienda è molto molto arrabbiata.
Non mi è consentito permettervi l'accesso per problemi di legge pricavy GDPR. Inoltre il sito è in produzione quindi ci serve per lavorare.

April 8, 2019 at 7:08 am #3554585

Fabio Massimo Pari

Un promemoria per te: avete già sui vostri server una copia del sito.

April 8, 2019 at 9:05 am #3555811

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Mi potresti dire in quale ticket hai inviato i dati per il server? perché io ho letto un ticket che diceva che per mancanza di risposta il server è stato cancellato.

Sempre per la legge sulla privacy, noi siamo tenuti a cancellare i siti al momento della chiusura del ticket o se il ticket è inattivo per 2 settimane.

Se mi dici in quale ticket avevi dato le info dei server, posso chiedere al collega che gestiva il sito di darmene accesso (ogni server è privato, sempre per la legge sulla privacy).

Comunque farò del mio meglio per capire cosa sta succedendo e cercare di risolvere il problema al più presto!

Saluti

April 8, 2019 at 9:38 am #3556113

Fabio Massimo Pari

https://wpml.org/forums/topic/turn-off-url-translation-for-product-categories/

April 8, 2019 at 2:09 pm #3558657

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao,

Allora, ho aggiornato il plugin e ho trovato la categoria hot tubs y poi ho visto la traduzione e sembra corretta.

Ti passo la pagina dello staging site in privato per vedere se riesci a riprodurre il problema lì. Se ce la fai, dimmi come l'hai fatto per poter controllare.

Saluti.

April 10, 2019 at 6:06 am #3572689

Fabio Massimo Pari

Abbiamo già fatto tutte queste prove e non abbiamo soluzioni.
Se devo investire altro tempo per risolvere la cosa credo che siate voi a doverci pagare.
Non è stato possibile identificare 1 singolo plugin a causare il problema.

Resta il fatto che il WPML quando aggiorno un prodotto in inglese genera automaticamente un nuovo slug usando parte del percorso base (che è in italiano) e ricreando il serto dell'indirizzo usanto il titolo della categoria.

Fateci sapere chiaramente se siete in grado di risolvere questa cosa. Abbiamo lavorato per voi molte ore per darvi il clone del sito e tutta l'assistenza possibile.

Ora la direzione di questa azienda non ha più pazienza e vuole risposte.

April 10, 2019 at 11:12 am #3575315

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Penso che il problema lo stia causando un plugin che hai attivo sul sito ma gli autori del plugin sembrano aver sistemato il problema:

Per quello che vedo basterebbe aggiornarlo e poi fare quel che dicono loro "Term permalinks are processed correctly when WPML enabled and "Adjust IDs for multilingual functionality" mode is activated"

Quindi devi andare su WPML > Lingue e cercare "Aggiusta ID per funzionalità multilingue" e assicurarti che sia attivo

Potresti farlo per favore e confermare che questo risolve il problema?

April 11, 2019 at 6:19 am #3583993

Fabio Massimo Pari

Il problema c'è ancora e gli aggiornamenti dei plugine e dei moduli li facciamo ogni giorno.

La funzione che hai chiesto di attivare era già attiva e lo è sempre stata.

April 11, 2019 at 6:44 am #3584133

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ok, in questo caso, per favore potresti controllare il sito di staging, dove non sembra presentarsi il problema e provare a riprodurlo così come sta (cioè con i plugin disattivati, ecc)?

Perché se non riesco a riprodurre il problema dalla mia parte, non potrò cercare la soluzione. se vedi che neanche a te si presenta il problema, allora per favore ti chiedo di provare ad attivare i plugin per vedere se uno di loro sta creando problemi di compatibilità.

Poi, sarebbe anche molto utile se mi potessi elencare i passi per poter riprodurre il problema perché forse mi sto saltando qualche passaggio.

Saluti.

April 11, 2019 at 7:50 am #3584549

Fabio Massimo Pari

I plugin sono gli stessi. Abbiamo solo ridotto il catalogo prodotti e rimosso i dati dei clienti.

La sequenza:

- modificare prodotto
- modificare dati in inglese (1)
- salvare modifiche (2)

Quando si salva lo slug viene modificato automaticamente nel modo sbagliato.

April 16, 2019 at 6:10 am #3618369

Fabio Massimo Pari

Siamo sempre in attesa di una soluzione.

April 17, 2019 at 3:40 pm #3632401

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Ciao, proprio lo stesso giorno che avevi scritto ti ho lasciato un messaggio privato, ma penso che non tu non l'abbia visto ancora. potresti vederlo e farmi sapere per favore?

Saluti.

April 18, 2019 at 7:41 am #3636873

Fabio Massimo Pari

Ho risposto al tuo video.

Noi non vediamo lo switch "usa l'editor di traduzione di WPML".
Comunque non è lo slug del prodotto il problema, ma quello della CATEGORIA e solo per le categorie che interessano il prodotto che viene modificato, solo nella lingua secondaria (inglese).

Comunque oggi abbiamo aggiornato tutto. Ora
woocommerce 3.6.1
woocommerce multilingual 4.6.0
flatsome 3.8.3
flatsome child 3.0

E non si è risolto nulla. Il problema rimane.

The topic ‘[Closed] Automatic translation of categories slug (AND WRONG!)’ is closed to new replies.