This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: I tried to update WPML Multilingual CMS 4.2.0 to 4.2.6 + string translation + media translation + sticky links, but I get this message: Download failed! Please refresh the page and try again.

Solution: I have followed below steps in order to fix this issue: - Deactivated and deleted WPML Multilingual CMS plugin. - Uploaded and activated updated version of WPML Multilingual CMS plugin from Plugins >> Add New page - Installed and activated WPML String Translation and Sticky Links plugins from Plugins >> Add New > Commercial Tab.

This topic contains 6 replies, has 2 voices.

Last updated by tommaso 5 months, 2 weeks ago.

Assigned support staff: Noman.

Author Posts
May 8, 2019 at 7:45 am #3764347

tommaso

Hi, I tried to update WPML Multilingual CMS 4.2.0 to 4.2.6 + string translation + media translation + stichy links, but I get this message: Download failed! Please refresh the page and try again.
I already registered the website, which is running wpml plugins already for several years.
Can you help?
Thanks, Fran

May 8, 2019 at 7:53 am #3764367

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thank you for contacting WPML Support. Sorry for the trouble, there were some update issue appeared with our WPML v4.2.0 release. Could you please delete and install WPML plugin manually?

To do a manual update please follow these steps:

1. Please take your full site backup.

2. Deactivate the existing WPML plugin.

3. Delete the plugin files – this does not delete your translations. You will simply delete the plugin files from your "wp-content/plugins" folder, NOT the database records.

4. Download the updated plugins from our servers (https://wpml.org/account/downloads/) and upload them to the plugin directory.

5. Activate the WPML plugin and add-ons.

Thank you

May 8, 2019 at 8:14 am #3764527

tommaso

Sorry, it's not that easy as in your instruction.
1 - in the folder wp-content/plugins there is no WPML Multilingual CMS folder. I just deleted all the other components such as wpml string transl. etc.
2 - I have to upload the new downloaded plugins via ftp, right? Well, should I upload them as zip file? How does it work?

Please give me more detailed instructions!

Thanks.

May 8, 2019 at 10:06 am #3765325

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

You can upload updated plugins from Plugins >> Add New page as you can see in the attached screenshot.

I can do it for you if you want. To do it please provide temporary access (WP-Admin and WPML Login info) to your site, so that I can look into your setup and debug the issue.

Your next answer will be private which means only you and I have access to it.

✙ I would additionally need your permission to de-activate and re-activate Plugins and the Theme, and to change configurations on the site. This is also a reason the backup is really important.

Thank you

May 9, 2019 at 6:40 am #3773355

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

WP login info that you have provided is not working here. Could you please provide me working login please. I have enabled private input box for your next reply.

Thank you

May 9, 2019 at 9:42 am #3774741

Noman
Supporter

Languages: English (English )

Timezone: Asia/Karachi (GMT+05:00)

Hi,

Thanks for login details. I have followed below steps in order to fix this issue:
- Deactivated and deleted WPML Multilingual CMS plugin.
- Uploaded and activated updated version of WPML Multilingual CMS plugin from Plugins >> Add New page
- Installed and activated WPML String Translation and Sticky Links plugins from Plugins >> Add New > Commercial Tab as you can see in the attached screenshot.

Could you please check and confirm?

Thank you

May 9, 2019 at 1:48 pm #3776689

tommaso

My issue is resolved now. Thank you!