Skip Navigation

This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This topic contains 12 replies, has 3 voices.

Last updated by Alejandro 1 month, 4 weeks ago.

Assisted by: Alejandro.

Author Posts
February 12, 2024 at 2:10 pm #15293521

romainO-2

Hello

I am trying to autotranslate shortcodes content from a third part plugin : member name, position and description.

Link to a page where the issue can be seen: hidden link

I have understood that I have to type things in the search bar to display the fields in the advanced editor but could you tell me which words I need to type to display all the fields ? Is there any kind of common tag that gather all these fields ?

Then, when I make appear some of them, I just can manually edit translation but it seems that I can't use credits to auto translate them.

Capture d’écran 2024-02-12 à 15.09.21.png
February 12, 2024 at 4:44 pm #15294117

Nicolas Viallet
Supporter

Languages: English (English ) French (Français )

Timezone: America/Lima (GMT-05:00)

Hi,

Welcome to the WPML support forum. Thanks for contacting us.

We are currently handling a high amount of ticket and while waiting for one of my colleagues to help with this ticket, please allow me to walk you through some initial debugging steps.

Could you please follow this documentation: https://wpml.org/documentation/support/language-configuration-files/translate-custom-shortcodes-with-wpml/

It will show you how to register custom shortcode to translation.

If the issue persist, or if you need further help, please provide as much detail as possible to my colleague:
- Provide a full shortcode example
- Provide the code you used in Custom XML Configuration

February 12, 2024 at 8:47 pm #15294787

romainO-2

It's working, thanks !

February 13, 2024 at 8:44 am #15295930

romainO-2

Actually, there is a bug left, some translated strings display are bad (see screenshot).

Please compare the french version (OK) : hidden link
And the english version (styling problem) : hidden link

Capture d’écran 2024-02-13 à 09.43.57.png
February 13, 2024 at 4:02 pm #15298810

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Did you do something to have the problem fixed? because i see both pages with the same styling and without any issues as you can see here:

- English -> hidden link
- French -> hidden link

If you do still see it that way, can you test it on another browser or in incognito mode and let me know what you see then?

February 13, 2024 at 4:11 pm #15298814

romainO-2

Hello,

Indeed, the problem fixed without any intervention from my side. Do you know what it could have come from ? And what to do for it not to reproduce ?

I had checked on another browser, also cleared the browser cache, and saw the same problem.

February 13, 2024 at 4:21 pm #15298831

romainO-2

Also, I have another problem. I can no longer display the changes I made to the English translation. I saved the translation several times. I also tried to re-save the French source version but I cannot display the new English translation.

February 13, 2024 at 5:27 pm #15299069

romainO-2

Same kind of problem on this page : hidden link
I have added one image and then removed it.
The image was well added and then removed on the english version but keeps displaying on the spanish version even after saving several times the translations : hidden link

b5ad9f12-201c-46a8-8d2b-0d28b6f4ac3f.png
February 13, 2024 at 5:36 pm #15299104

romainO-2

[edit] "Also, I have another problem. I can no longer display the changes I made to the English translation. I saved the translation several times. I also tried to re-save the French source version but I cannot display the new English translation." ----> It took several hours but it resolved itself without me doing anything. What is due? Is there any cache problem ? (The cache plugin is disabled)

February 13, 2024 at 6:42 pm #15299253

romainO-2

[edit] "Same kind of problem on this page : hidden link" ---> same behaviour, 2h later, the modification is finally taken into account. Why so long ?

February 14, 2024 at 8:10 am #15300374

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

Hi there,

From what I see it's very likely the problem could've happened because of some cache, probably a server-side one.

When you see issues "resolve itself" it's almost always because of some sort of cache. I remember that divi also has some cache that.you can flush on its setting but in here it sounds more like a cache coming from the server, something like OPCACHE, for example and, in this case you can talk to your hosting so they can flush it for you or tell you how to activate or deactivate it for testing purposes.

You can rest assured that what you are experiencing has nothing to do with WPML since the first issue you mentioned was handled by the theme and the second by WordPress itself.

February 14, 2024 at 10:17 am #15301162

romainO-2

Ok, I will have a look. Is there some cache on the WPML side that I can test to flush too ?

February 14, 2024 at 7:06 pm #15304225

Alejandro
Supporter

Languages: English (English ) Spanish (Español ) Italian (Italiano )

Timezone: Europe/Rome (GMT+02:00)

THere is only for the language switcher template and can be flushed in WPML > Support > Troubleshooting, however i don't think this one applies to your situation.

Let me know how it goes.

February 22, 2024 at 6:29 pm #15335321

romainO-2

Ok thank you

romainO-2 confirmed that the issue was resolved on 2024-02-22 18:29:17.
This ticket is now closed. If you're a WPML client and need related help, please open a new support ticket.