This is the technical support forum for WPML - the multilingual WordPress plugin.

Everyone can read, but only WPML clients can post here. WPML team is replying on the forum 6 days per week, 22 hours per day.

This thread is resolved. Here is a description of the problem and solution.

Problem: The font awesome icons are not showing in my secondary language when I use Avada theme

Solution: This was happening because the Avada option the font awesome was disabled.

This topic contains 7 replies, has 2 voices.

Last updated by rodolfoR-2 1 year ago.

Assigned support staff: Lauren.

Author Posts
September 10, 2018 at 10:07 am #2719547

rodolfoR-2

Hello,
i have an issue with Avada 5.6.2.
Wordpress 4.9.8.
WPML Media 2.3.6
WPML Multilingual CMS 4.0.6
WPML String Translation 2.8.6
WPML Translation Management 2.6.6

I have a three-languages website. I can see font awesom icons only for english.
Please see the attachment that includes element inspector.
Thanks

September 11, 2018 at 5:37 pm #2724773

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thank you for contacting WPML support. I'll be happy to help you with this.

Can you please tell me how you are adding the icons? Are you using a page builder? Also, did you translate the content using manual translation, or by using the translation editor?

Please make sure your website meets the minimum requirements found here: https://wpml.org/home/minimum-requirements/. Specifically, please increase your WP Memory and if possible, update your PHP version. Does this resolve the issue?

If not, I'd like to have you try a few things so we can try to isolate the issue. This is just to help me identify if it might be a conflict with another plugin or theme that is causing the problem.

** IMPORTANT ** Please backup a working copy of site files and database before continuing.

Update all WPML plugins & WordPress core.

Disable all plugins except WPML related and then temporarily change the theme to a default WordPress such as TwentyFifteen. With these settings, do you see the fontawesome icons in secondary languages?

September 25, 2018 at 9:26 am #2763174

rodolfoR-2

Hello Lauren,
we use Avada Fusion Builder to add icons. Icons are on a Checklist and Content Boxes.
Content was originally only in italian, then we have added english and spanish translation.
This in an example of text code, the same for IT(dont' word) and EN(works):

[fusion_checklist icon="fa-arrow-right fas" iconcolor="" circle="" circlecolor="#065f5e" size="13px" divider="" divider_color="" hide_on_mobile="small-visibility,medium-visibility,large-visibility" class="" id=""]+
[fusion_li_item icon=""]first[/fusion_li_item]
[fusion_li_item icon=""]second[/fusion_li_item]
[/fusion_checklist]

I have change the theme to Twenty Fifteen and the icons are correctly shown on the three languages.

September 25, 2018 at 4:03 pm #2764671

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Since the icons are showing correctly with a default theme, I suspect this is a conflict with your theme. If you switch to Avada parent theme, do you still have the issue? Are you using the latest version of Avada, and are there any available patches that need to be applied?

September 26, 2018 at 6:56 am #2766068

rodolfoR-2

With Avada parent theme i still have the issue. I'm using the latest version of Avada and no patches are available.

September 26, 2018 at 3:57 pm #2768016

Lauren
Supporter

Languages: English (English )

Timezone: America/New_York (GMT-04:00)

Thanks for testing that. I set up a fresh install with Avada theme and I am seeing the icons in all languages. Please login and check if you have any different settings than I do on my test site:

Login: hidden link
Username: demo
Password: 4x20Q9zLWJcd

Test Pages:
hidden link
hidden link

I also found this article on the ThemeFusion website: hidden link

Please try that solution as well, since this could be due to your permissions or server settings. Please let me know if you need any further assistance and I will be happy to help.

October 2, 2018 at 9:09 am #2780771

rodolfoR-2

Hello Lauren,
i made some tests on your installation and it works.
I could't find the solution by matching the two installation.
I can say that, if i create a new IT page with some fontawesome icon, the page code misses the row
<link rel='stylesheet' id='avada-IE-fontawesome-css' href='hidden link' type='text/css' media='all' />

October 2, 2018 at 9:17 am #2780830

rodolfoR-2

Hello Lauren, finally i have found the solution... for some reason on Avada option the font awesome was disabled.
Thanks for your support!